10925 questions

13028 answers

20309 comments

27373 members

0 votes
121 views 0 comments
by

Don't work Update Interval (in seconds)  on RUT240 (RUT2_R_00.07.01.4).

RUT240 synch time only after restart or SAVE&APPLY config.

1 Answer

0 votes
by

Hi Alex,

We are facing some issues with update internal option as well. RnD will come up with some solution very soon. However, for now you can create a crontab job for your ntp client as mentioned below

* * * * * /etc/init.d/ntpclient restart >/dev/null 2>&1

The above crontab job will be executed every 1 minutes. Every one minute it will restart the ntp client deamon, which will sync to ntp server automatically every time ntpclient instance is restarted. 

To configure this, go to CLI of the router and enter your credentials. Enter into crontab editor with following command:

crontab -e

here press i to start editing and enter the * * * * * /etc/init.d/ntpclient restart >/dev/null 2>&1 line in it. Do not delete anything from the crontab file.

press esc, after you are done with editing and then type :wq and press enter.

now to check wheather the job is being executed properly or not, issue logread -f command.

To capture ntpclient packets, install tcpdump package from package manager and issue the following command in CLI:

tcpdump -i wwan0 port 123

here wwan0 is the mobile interface which is used by my router to connect to ntp server and 123 is the ntp port number. You will see the results like below:

Apart from the above solution, you can also check and enable ntp client in /etc/config/system file through CLI, as it syncs automatically roughly every 30 seconds.

for this, go to CLI and issue below command:

vi /etc/config/system

press i to start editing and enable the ntp config as shown in the picture below

press esc after editing and then :wq and press enter to save and exit.

After changing configuration enter the below command in CLI:

reload_config

Make sure you enter the above command as it is really important.

Regards

Ramandeep