FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12692 questions

15070 answers

24150 comments

47148 members

0 votes
156 views 2 comments
by
<!--[if gte mso 9]> <![endif]--><!--[if gte mso 9]> Normal 0 21 false false false BG X-NONE X-NONE <![endif]--><!--[if gte mso 9]> <![endif]--><!--[if gte mso 10]> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:8.0pt; mso-para-margin-left:0cm; line-height:107%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri",sans-serif; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi; mso-fareast-language:EN-US;} <![endif]-->

Hello,

I have RUT955 connected as a client to our OpenVPN server. I need to route two networks (192.168.3.0\25 and 192.168.3.128\25) from RUT955 through OvenVPN tunnel to our server, but i manage to connect to only one network at a time. I want to be able to ping and connect to devices on both networks.

In interface configuration I create second interface and in physical settings bind it to corresponding interface (drawn from CLI – ifconfig), but still only one network works at a time.

Every help will be much appreciated.

<!--[if gte mso 9]> <![endif]--><!--[if gte mso 9]> Normal 0 21 false false false BG X-NONE X-NONE <![endif]--><!--[if gte mso 9]> <![endif]--><!--[if gte mso 10]> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:8.0pt; mso-para-margin-left:0cm; line-height:107%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri",sans-serif; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi; mso-fareast-language:EN-US;} <![endif]-->

1 Answer

0 votes
by

Hello, 

From what I understand you were able to set up the tunnel and connect to the OpenVPN server, correct? If so, I imagine you are connecting to only one network through the Remote network IP address option. You can add the other one by creating a static route, where you can put the address you want to reach and the Gateway where it should be sent to reach that address. In this case, it should be the IP of the created tunnel. Here is a link with the settings for a static route. 

https://wiki.teltonika-networks.com/view/RUT955_Routing#Static_Routes

Keep in mind that you may have to add another route to this final address in the server so you can reach it without any problem.

by

Hello,

Thanks for replying.

At first we tried with static routes, with no result. We noticed that it's the interface that is not working properly. We made it work when the first interface (in physical settings) is in bridged mode and the second interface is not in bridged mode and selected as newly configured Interface.

LAN2

by
Hey,

I would have to know a little more about how you are creating the static route. As you mention, it may work for both networks if you bridge between the two. That's another possibility you have to make it work. However, within the same router, you are connecting these two different networks, which I don't know if in your case you want it to.