subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
223 views 3 comments
by anonymous


The IPv6 part of the address returned by gsmct is in dotted decimal format:

root@lgrrutx:~# gsmctl -p mob1s1a1,

The result of gsmctl -A "AT+CGPADDR=1" is similar, as is the output of %mi in Events Reporting.

Is there a way to have the IPv6 addresses in the standard column separated format at least for gsmctl -p and %mi ?


1 Answer

0 votes
by anonymous


Thank you for your feedback.

This particular issue will be resolved in next upcoming RUTX firmware release (version 7.2), which we hope will be released in upcoming weeks.

Best answer
by anonymous

In version 07.02 neither gsmctl -p nor %mi report the IPv6 address. gsmctl -A "AT+CGPADDR=1" still gives a dotted decimal formatted one.

by anonymous

Hello, is it possible, that typing error occurred when executing commands?

Of maybe you have updated firmware be keeping all previous settings? If this is the case, could you try to restore device to factory default settings and try to check this aspects again?

We have tried to use gsmctl -p <interface_name> option and it worked correctly:

root@Teltonika-RUTX09:~# cat /etc/version
root@Teltonika-RUTX09:~# gsmctl -p all
root@Teltonika-RUTX09:~# gsmctl -p mob1s1a1
by anonymous

After a reset to factory defaults and re-enable PDP type = IPV4/IPV6:

wwan0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 inet addr: P-t-P: Mask: inet6 addr: 2a02:8440:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx/64 Scope:Global inet6 addr: fe80::b35f:f74b:e9bb:934c/64 Scope:Link UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1 RX packets:169 errors:0 dropped:0 overruns:0 frame:0 TX packets:225 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:41934 (40.9 KiB) TX bytes:24792 (24.2 KiB) 

root@lgrrutx:~# gsmctl -p mob1s1a1
Idem for %mi the IPv6 part is absent.
Have you tested a configuration where both IPv4 and IPv6 are active ?