FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
356 views 4 comments
by anonymous

Hello!

We have a TRB245 placed out in the field. It has been working great for a while as a modbus serial gateway, but it recently stopped accepting connections.

After further investigation the menu item for "modbus serial" is missing in the web interface. Trying to start the modbus_serial_master from command line throws the following error:

root@Teltonika-TRB245:~# modbus_serial_master  --rs485 19200
Failed to open serial device

Advanced mode is selected in the GUI.

Help?

1 Answer

0 votes
by anonymous

Hello,

From the screenshot you have provided, it can be seen that no RS232 or RS485 section is displayed. I believe this is what you are missing. In this case you can try a couple of things:

  If none of this helps, it is highly likely that the issue is related to a hardware failure and you should return the device. 

Best regards,

Žygimantas

by anonymous

Thanks for the suggestions.

Reboot is not helping unfortunately. I only have access to the TRB245 over ZeroTier, so using the Bootloader menu externally seems to be a no-go. I would have to go and collect the device in order to try that.

Here's a screenshot of ls /dev

by anonymous
Hello,

Apparently, RS232 and RS485 instances are missing, which is another indicator of hardware failure.

Best regards,

Žygimantas
by anonymous
So I went a purchased another device, and the same thing has happened with that one. RS484/RS232 menu is missing in the menu after a while of working perfectly, any idea why this is happening?
by anonymous
Could you provide any description, schematic or photo of your setup?