10456 questions

12462 answers

19387 comments

21898 members

0 votes
81 views 5 comments
by
Hello,

We have upgraded our RUTX12 modem to newest firmware. However, after upgrade, even though, the modem is working, but our existing ROS structure is not working. Nothing changed in the network. To make sure that the problem is related to the firmware, we downgraded to the working version, and it start to work again.

The working firmware is `RUTX_R_00.07.00`

The firmware that doesn't work is `RUTX_R_00.07.01.4`

2 Answers

0 votes
by
Hello,

Could you please provide more details on what exactly stops working?

What is your network topology, ROS structure?

What configuration changes are made to the router?

Best regards,

Žygimantas
by
Hi Žygimantas,

Thanks a lot, just added more details in above.
0 votes
by

When we use ROS demo (Talker/Listener) on old firmware, it works normally. However, When we just upgrade the firmware, it stops working. Not message are received on listener side.

The network configuration is depicted in below picture. We have two OpenVPN server running in the AWS cloud. The PC1 and PC2 are connected to with these VPNs. We use ROS to pass the massages between host by using these hosts.

After upgrading the firmware, we just didn't change any configuration. we hold the working configuration.

 

by

Did you update with the Keep settings button on? If the configuration did work with the previous firmware version, it is recommended to reset the updated device to factory defaults and try to configure your VPN settings again.

by
Yes, We kept the configuration. I will test with a fresh upgrade without any old configuration.
by
We just tested with newest version and factory reset. But it still has problem with `fastRTPS`
by

I would like you to send me a troubleshoot file. Please, replicate the issue, then access router's WebUI, go to System -> Administration Troubleshoot section and download troubleshoot file from there. Maybe some issues will show up there.

Best regards,

Žygimantas