subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
378 views 4 comments
by anonymous
Hello there,
i have my hands on teltonika rutx12 for few days for testing. I need it to work this way:
I have 4 houses with security cameras + alarms and want upload data to FTP server. But if send all houses to 1 SIM, i will exceed data limit, so for my case this dual sim teltonika rutx12 seems to be perfect solution, because i can divide 2 houses to SIM1 and 2 houses to SIM2. At other side there is an synology ftp server.

I get that Teltonika, tried to configure it the best i Can, set APN, port forward to synology, set load balance to 50/50 between the 2 mobile interfaces.

Also i have set within advanced static routes via Look table and rules that any device from this network will use modem 1 for going out to network. (but my case was even before this setup)

Its working this way:
If i start uploading data from house 1 to SIM1, its working. If i connect house 2 to SIm1, its working, everything is going to FTP. But when i start uploading house 3 to SIM2, everything crashes, modem1 gets disconnected and tries to re-connect, modem 2 will not even start upload to FTP. This goes on until i cancel upload to SIM2, then, after while, modem 1 re-connects properrly and continues uploading.
I have tired to stop upload to SIM1 and force upload only to SIM2, but it also would not start, its like the second modem couldnt find its way to synology, or is fighting with modem 1.
In port forwarding its set that from any WAN IP, to any router IP, everything sent to synology at port 21.

If i tired to make separate VLAN for interface lan2, and setp up that this interface will use modem 2 to going out to network, it was working well. PC1 gets out through modem 1 and PC2 through modem 2. So modems are working, separatelly. But when the router needs to merge data from both modems to single output (synology), then its not working.

Any idea why is this happening?

1 Answer

0 votes
by anonymous


Are these 4 houses connected to each LAN port of the RUTX12? If not, please provide us with a topology diagram of the network to understand better.

What firmware version are you using? Please, make sure you are using the latest one (RUTX_R_00.07.01.4). If you need to upgrade, you can download it on the wiki page:

RUTX12 Firmware Downloads - Teltonika Networks Wiki (

We do have a configuration example for splitting LAN traffic to go through different mobile interfaces on a RUTX12. You can check it on the following wiki page:

LAN Traffic Splitting Using Advanced Static Routing Rules - Teltonika Networks Wiki (

Another possible option for your scenario would be establishing a data limit for SIM1 and a failover configuration so the traffic goes to SIM2 if the first one is unavailable. You can verify the Mobile Data Limit feature on the option Networks > Interfaces > Edit Interface MOB1S1A1 > Mobile Data Limit. You can check the options on the following wiki page:

LAN Traffic Splitting Using Advanced Static Routing Rules - Teltonika Networks Wiki (

Kind regards.

by anonymous


Thanks for answer. 

I have uploaded image of the network how does it looks like. 

What i need is: 

I have 2 IP from provider, i need to send data from security cameras from house 1 and 2 to IP1, and from house 3 and 4 to IP2. Router need to receive them and send everything to Synology. Also i need that PC will get out to network with primary modem IP1. 

Port forwarding is set that any data sent to any router IP, forward it to synology. 

Load balance is 50/50.

Advanced static route is set that everything from interface lan use primary modem in first place. 

Everything is working for IP1, but i cant send data to IP2, secondary modem is doimg weird thing described in main question, it looks like it cannot see the synology or that modem cannot merge data from both modems. 

PC is gettimg out with primary modem without problem. 

I have read entire section for rutx12 few times trying to find out whats wrong. 

I cannot do it your way, i need to set up static IP to FTP information section to camera systems and alarms. 

by anonymous


About the network topology, could you specify how the connection works from the cameras to the SIMs? The 4G connectivity goes through a mobile modem on each house? Could you comment what brand and model the cameras are?

Also, the load balance is configured for outgoing traffic so in your case, it would not be necessary to implement it, since your outgoing traffic only goes through SIM1. 

I assume you are already using the latest firmware version. Please, recreate the failure scenario, and share the Troubleshoot file (System > Administration > Troubleshoot > Troubleshoot file) so we can check the logs. To share this file you can edit your first post and attach it.

Kind regards.

by anonymous
Each house have its own system taht is connected to LTE modem. They are all standard HIKVision systems, but in this case its irelevant because as i say, its working for the primary modem on IP1, only the secondary modem IP2 is some kind of faulty.

I have tried it also without load balance in the start of configuration and it was doing the same, there was no difference between load balance on/off.

I have borrowed the Teltonika, i have it for 3 more days then i need to sent it back. I can check the firmware update ut i dont know if I am able to update it, because then maybe i would not be able to sent it back. I will check it out.

Send me your e-mail please andi will send you the troubleshot file.
by anonymous

I sent you a private message. You can reply with the attached file. Please, make sure you replicate the crashing scenario before generating the troubleshoot file.

Kind regards.