10879 questions

12963 answers


26145 members

0 votes
83 views 2 comments
I have two RUTX1 that failed to re-connect to RMS due to TLS error, NTP looks ok


RMS setting from the GUI

1 Answer

0 votes

Hi Felix,

Please first check you have internet connectivity on the routers. Also, login into the RMS platform, hover your mouse over the left bottom corner of the screen, select the Services tab and click on Management. Verify that your monitoring service on both devices has not expired and that you have enough credits remaining. You will get an output similar to the image in the link below:


If the Monitoring service is no longer active and you don’t have enough credits remaining, you will have to buy more RMS Credits to continue monitoring your devices. To buy more credits, click the Buy Credits button; it will redirect you to the webpage where you will find out how to buy more credits. However, if you have enough credits left but the Auto Extend feature is not on, you will have to manually activate your Monitoring service again after your 1-month monitoring service expires.

If everything is in order, login into your router Command-line interfaces and execute the following command:  rm /etc/rms_mqtt/c*. Now login into your router WebUI and select Services > Cloud Solutions > RMS. In RMS settings, check whether your connection state is connected or not. If it still displays a TLS error connection, select connection type, switch it to disable, click on Save and Apply button and wait for a few seconds while the page is loading. After the webpage finishes loading, return the connection type field to enable, click Save and Apply again and verify your router connection state changes from connecting to connected.

In case anything from the above help to solve the issue, please restore your router configuration to defaults. Refer to the link below to do a factory reset procedure:


I look forward to reading your comments.



1. Device is not "online" in the RMS platform, and monitoring is enabled and still have 2 credits left and devices are set to expired : 2022-05-31 14:45:41 - device is oob-cph-p02 and oob-cph-p01

2. It works if I do "rm /etc/rms_mqtt/c*" - it is a little lucky because we not yet deployed multiple Teltonika routers yet (if we had, we had no access)

3. Let me do the same on "oob-cph-p02" when I get into the office tomorrow