11324 questions

13494 answers

21161 comments

31592 members

0 votes
204 views 18 comments
by

Dear teltonika-team,

Blacklisting seems not working: 
After adding a new OperatorList (e.g. called "Swiss" which just one operator-number as an example e.g. 22801) and enabling the Blacklisting with this small list, the mobile-connection immediately stop working. 

Many thx for help,
Rainer

1 Answer

+1 vote
by
Hello,

Could you please specify your problem.

Blacklisting operators blocks all operators in that list, thus, if you have included the code of the operator you are currently using, consequently, you loose your mobile connection.

Best regards,

Žygimantas
by

Hello,

A couple of suggestions: 

1. Instead of using automatic APN setting, set it manually.

In the WebUI navigate to Network -> Interfaces and edit mobile interface settings. Disable Auto APN and enter it manually.

2 Update modem firmware.

Before attempting the update, you need to connect your router a different WAN source, either wired or wireless. Below are the the instructions:

  • Access your device via SSH and execute the following commands:
    • opkg update
    • opkg install modem_updater
    • opkg install sshfs
    • modem_updater -g
  • The last command will list available firmware versions. Next modify the following command:
    • modem_updater -i <ID> -v <VERSION>
      • <ID> - should be 1-1.4, however, in case of an error you should be shown a correct ID.
      • <VERSION> - enter the latest firmware version from the list of the previously executed command it should be EC25EUGAR08A01M4G.

Best regards,

 

by

Many thx.

I did modem-update as you mentioned successfully and I checked after a fresh reboot, but the issue is the same:
Blacklisting Operators does not work at all.

You could simply test by your own with your own operator-id:

a) "gsmctl -f" show for me OperatorNumber "26202" (which is Vodafone in Germany)
b) Under Network->Mobile I create a OperatorList and add this List to SIM2 by Enabling "Blacklisting" under "Operator Settings"
c) After Saving and Rebooting the Router starts with SIM1 (default; Now I do a simple "ubus call sim change" to switch to SIM2
d) After switch I see unfortunately SIM2 is fully working :-|
e) Settings look fine:
    >>> uci show operctl | tail -3
    operctl.@operlist[2]=operlist
    operctl.@operlist[2].name='EigenerVodafoneOperator'
    operctl.@operlist[2].mcc_mnc='26202'

What else can I do?

Best regards,
Rainer

by
When enabling blacklisting, you should be prompted with a message at the bottom right of the configuration page: "Your SIM card provider will not be blocked even if blacklisted". Thus, SIM2 fully working is correct behavior, even with its operator blacklisted.
by

You are so right - I interpreted the popup-message in a bit different way, sorry for this.

So how to test Blacklisting is now working? :

a) I scanned for all operators on my SIM-card and found 26201, 26202 and 2603 (where 26202 is my default after reboot).
b) Then I set operator-selection/scan to "manual" for this SIM and just set 26201, I saw this is working fine on 26201.
c) Then I set a blacklist with just operator 26201 for this SIM and did reboot; but SIM still just uses 26201 properly and ignore the blacklisting, despite 26202 is the default-operator.

Result: Blacklisting cannot be tested since it looks like the router treats the defined 26201 as new default-operator?!?

How could I test now blacklisting is working (which did not worked in 7.02.1 when I travelled between Italy->Swiss->Germany in June).
Many thx, Rainer

by
Any news?
Many thx, Rainer