FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
651 views 3 comments
by anonymous
Good morning everyone.

Seems that failover/balancing procedure creates me some troubles when there is only one interface with internet access as the wireless mobile connection.

So, I need to FULL DISABLING  failover and balancing mecchanism to avoid thath a temporally missing 3G/4G connection become a trigger for a more wrost networking fails situation.

Please, how can I full disable this procedure ?

Thanks

Amos

1 Answer

0 votes
by anonymous

Hello,

You can disable failover simply by logging into the device's WebUI, navigating to Network -> Failover and setting the slider buttons next to the interfaces to off position. 

You can also login to device's via SSH and enter the command below to stop the mwan3 service providing failover and load balancing functionalities:

  • /etc/init.d/mwan3 stop

On the other hand, you can configure the number of attempts for each interface to test connectivity and set the interval between each attempt to increase the time duration before switching to the next available WAN interface is performed.

Best regards,

Žygimantas 

Best answer
by anonymous

Thanks Žygimantas for reply.

Seems that a UI method not really disable failover in all situations, I believe that I have found traces of this task activity in the logs .
So "/etc/init.d/mwan3 stop" appear for me the best way.

Please, there is a way to hold this parameter after boot  ?

Thanks again
Best Regards

Amos

by anonymous

Hi,

There is a file in /etc directory called rc.local. It is used to store commands and scripts, which are executed once the system startup and initialization procedures are finished. Try adding the command there.

Best regards,

Žygimantas

by anonymous
Hi,

starting from your advice, in legacy firmware,  I found this possibility :  

 /etc/init.d/multiwan stop
 /etc/init.d/multiwan disable

But, I was amazed how in the RUT9XX the problem is triggered by the inability to use the LTE band 7  with the latest firmwares.

I found there are some tasks in the forum about it.

Best Regards

Amos