subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
518 views 6 comments
by anonymous

Hi, We are using the RUT240 and have been for years using FTP onto the LAN device, recently we upgraded some units to the latest FW:RUT2_R_00.07.02.1 since this upgrade the FTP21 file transfer isn't working.

With older FW this worked without any problems on the same device. Is there something with this new FW which is blocking the file transfer back to source?  I can connect to the LAN device but this won't open the file location.

Response: 200 TYPE Command okay.

Command: LIST

Response: 150 File status okay; about to open data connection.

Response: 425 LIST can't open data connection.

Error: Could not retrieve directory listing

I have found If I remotely reboot the RUT240, I can connect to the FTP file for a minute or so, but then again blocked.


Added troubleshoot file as requested..

by anonymous
Could you downgrade and attach a troubleshoot file from the working device?

2 Answers

0 votes
by anonymous


I would like you to generate a troubleshoot file to your question with the issue present. To generate a troubleshoot file, access router's WebUI, go to System -> Administration > Troubleshoot section and download troubleshoot file from there.

Next, I would like you to try the following. Connect to the router via CLI/SSH and enter the following command:

  • ip -4 rule delete $(ip -4 rule show| grep 2062 | cut -d":" -f 2)

If that works, please attach the troubleshoot file by editing your question.

Best regards,


by anonymous
Hi, Have you been able to look into this further, I've now tried the latest FW2.2.7 and this is also not working, do you know if there as another firewall setting I need to allow?

Just to confirm, we're using a Static IP sim card and allowed the port 21 onto the LAN device, this has working on all the older FW routers  without any problems. Can you please advise, as this is now causing issues as all new routers are now provided with this FW and FTP isn't working. is it possible to downgrade routers to a working version?
by anonymous


Could you connect to one of the devices via CLI or SSH and execute the following commands and see if that helps:

echo "net.netfilter.nf_conntrack_helper=1" >> /etc/sysctl.d/11-nf-conntrack.conf


/etc/init.d/sysctl restart

by anonymous

Yes, I set this command and this now accepts the FTP,  

Do I need to manually do this on all my routers when upgrading FW?


Gareth Rynn
by anonymous
Likely, yes.

There seems to be an issue with misconfiguring FTP related firewall settings.

Currently, changes are scheduled to be included only in 7.6 firmware release, which is not coming out anytime soon.
by anonymous
We also have this issue on an RUT950 with RUT9_R_00.07.02.7 firmware.

The above fix worked for us and I initially added it to the startup  script, however this results in another net.netfilter.nf_conntrack_helper=1 being added to /etc/sysctl.d/11-nf-conntrack.conf after each reboot.

Anyone from Teltonika care to comment?
0 votes
by anonymous
Same problem here. Fixed with the cli command. Does anybody knows the release date of 7.4, that should fix this issue?