11341 questions

13514 answers

21177 comments

31665 members

0 votes
86 views 0 comments
by
We had a issue with a RUT955 (FW ver.: RUT9XX_R_00.06.09.1) connected to two openvpn server the same time. From one server we were able to connect to the device Modbus server, from the other not. (We ran the same setup on other devices successfully).

After downloading the backup of the not working device and comparing the diff with a working on, we figured out there is a difference in the file /etc/config/firewall in the section config zone 'vpn zone'. The working one has a entry like option device 'tun_+ tun+', the none working one is missing the tun+ there.

After fixing that via ssh and vi it's working as expected.

But we don't want to connect via ssh to every device, so the question - where to set this in the front end?

1 Answer

0 votes
by

Hello,

It is recommended to upgrade the firmware to the latest available version (RUT9_R_00.07.02.1) which you can upgrade going to the option System > Firmware > Upgrade. You can choose to upgrade the firmware from server or from file, which you can download on the following wikipage:

RUT955 Firmware Downloads - Teltonika Networks Wiki (teltonika-networks.com)

If you don’t proceed with the firmware upgrade, you can check the zone configuration by going to option Network > Firewall > Zone Forwarding. There you can edit the OpenVPN zone to forward the packages to another zone, like you can see on the following wikipage:

RUT955 Firewall (legacy WebUI) - Teltonika Networks Wiki (teltonika-networks.com)

The OpenVPN zone should be created automatically. If you don’t find it on you config file, you should try to do the firmware upgrade and configure the VPN again. The newer firmware allows you to create new inter-zone forwarding rules on webUI. You can check this option on the wikipage:

RUT955 Firewall - Teltonika Networks Wiki (teltonika-networks.com)

Kind regards.