FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12681 questions

15065 answers

24134 comments

47098 members

+1 vote
203 views 2 comments
by

Good Morning,

Printing date demonstrates that the system clock has wrong value. It even shows GMT time but it is EST time.

Fri Jun 24 11:13:13 GMT 2022

We have firmware RUT9XX_R_00.06.09.2. For some reason in our application we need to use only legacy firmwares.

Could you please tell us how to fix this issue so that system clock will show the correct time that is UTC time right now? (Fri Jun 24 09:13:13 GMT 2022)

We have tried as well to turn on the GPS synchronozation but that we will cause a time jump from UTC to EST every some minutes.

We will greatly appreciate your help!

Best regards,

Parian

by

Hi, maybe this can help you, I follow these steps to change local time, in this case to 'Europe/Madrid':

uci set system.system.timezone='CET-1CEST,M3.5.0,M10.5.0/3'

uci set system.system.zoneName='Europe/Madrid'

uci commit system

/etc/init.d/system restart

uci show system

And to perform a subtle adjust:

date -s 2022.04.21-10:46  using this format: [YYYY.]MM.DD-hh:mm[:ss]

BR

MC

1 Answer

0 votes
by
Hello Parian,

You can use UCI commands as mentioned by Miguelangel.

Also, you can use the NTP protocol in the services section of the router.

Note: Before using the NTP protocol use the following commands to update the NTP package to configure the NTP servers.

<opkg update >

< opkg install ntpd >

These commands will help you to install Time Server configurations options in the router.

This can help you to configure the time synchronization settings with GPS as well as the operator station and NTP servers.

Regards,

Shivang
by

I'm working on it. I'll let you know