FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
213 views 2 comments
by anonymous
Hi there.

Has anyone actually got Wireguard to work on the RUT955 (older hardware RUT955H7VXXX) with firmware 6.09.2 ??

I've got it working just fine with newer RUT955 hardware on v7 firmwares, but I simply can't get a handshake from any v6 firmware.  

If I look at "Status -> Network -> Wireguard"  I see the message "There are no Wireguard configurations yet", although if I look in the GUI under Services -> VPN -> Wireguard, it's all there.  Also I can see the config is there and enabled from the cli, using the uci show network command.

I've wasted too much time on this.  Any help would be appreciated.

Thanks

Tino

1 Answer

0 votes
by anonymous
Hi Tinot,

Could you please try to install the factory FM RUT9XX_R_00.06.08.6 and try again? Please do not keep configuration from the previous FM.

If it does not work, please draw your topology and attach it together with a troubleshoot file so i can try to the help you. Also, open the CLI of the device and type "wg" and let me know what it gives to you.

Thanks
by anonymous

OK. Installing 6.08.6 now.  Will report back

Reporting back: 

Still doesn't work.  Exactly the same issue. 

Very simple topology that works just fine with newer versions of the RUT955.

wg output from CLI:

   Teltonika RUT9 series 2020

 ---------------------------------

root@Teltonika-RUT955:~# wg

root@Teltonika-RUT955:~# 

From the GUI looking at "Status -> Network -> Wireguard" gives:

However, you can clearly see that I have configured the settings as needed in the GUI in the pics below:

The config works just fine on v7 firmware on newer devices.  I simply can't get it to work with anything v6 related at all on the h7v based hardware.

by anonymous
Any suggestions folks.  It'd be a shame to see v6 firmware not support Wireguard for older devices.