FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

11981 questions

14261 answers

22478 comments

35629 members

0 votes
257 views 6 comments
by

Dear Forum, 

we are facing this problem on 10+ Routers. We can receive SMS, but not send them. 

Router model Teltonika RUT955 LTE
Firmware version RUT9XX_R_00.06.08.5
Kernel version 3.18.44
Bootloader version 3.2.7         
Model SLM750
FW version SLM750_4.0.6_EQ101

We have tried to send SMS from the Webui and from the Cli. We always get the timeout error. It only seems to happen with a specific network provider. But if we put the SIM Card into any other device, it works fine. We can send and receive SMS. So the problem must be on the Teltonika Modem.

We have used the same settings. Internet connection via Mobile and receiving SMS works, but not sending. This Problems occurs on more than 10 Routers, they all use the same FW and have the same HW Revision.

I've checked the System Logs and the troubleshoot file, but i can't find any obvious error there. 

Which steps could we take to solve this problem?

Thank you

2 Answers

0 votes
by

Hello,

What is the provider of your mobile services?

Have you tried to send SMS using a different provider SIM card?

You can try the following on one of the devices.

  • Access your device via SSH and execute the following commands:

  • opkg update
  • opkg install modem_updater
  • opkg install sshfs
  • modem_updater -g

  • The last command will list available firmware versions. Next modify the following command:

  • modem_updater -i <ID> -v <VERSION>

  • <ID> - should be 1-1.4, however, in case of an error you should be shown a correct ID.

  • <VERSION> - enter the latest firmware version from the list of the previously executed command.

If it does not help, please replicate the issue, generate a troubleshoot file and attach it to your question.

Best regards,

Žygimantas

by

Hi, 

Thank you for the answer.

1. The provider is an italian one, TIM (telecom italia). It works with other providers like vodafone.

2. Update device firmware to the latest - we can not do that. This FW Version is not released as stable candidate and we have tremendous problems after upgrading the firmware. As the Stations are remote, the VPN (Strongswan IPSec) does not work anymore after a reboot and the Station is offline. Also SNMP stops working after a FW upgrade. 

Can i just update the Modem FW without updating the Teltonika FW? Or will that break things?

For the troubleshoot file i would have to edit that and cut out sensitive information.

by

Hello,

It might be that TIM has LTE-only network, thus I would like you to try the following:

Login to the router's WebUI, navigate to Network -> Mobile, set VoLTE setting to On and service mode to 4G(LTE) only.

Save these settings, see if that helps.

Best regards,

Žygimantas 

by

Hi, 

sorry for the late reply i was on PTO.

I can't see any option for VoLTE? I tried Service mode automatic, 4g, 3g and 4g but still can't send sms.

by

In legacy firmwares, the option is accessible via CLI/SSH.

To enable VoLTE, what you need to do is to:

  • Navigate to Services -> CLI;
  • Use root as username and your router's password;
  • Enter: vi /etc/config/simcard;
  • Navigate to option volte for a relevant SIM card, press i to enter editing mode and replace '0' to '1';
  • Press :wq and enter;
  • Execute the following command: /etc/init.d/network restart.

Check if that helps.

Is there any reason why you use this firmware, do you have a legacy hardware device (product codes containing: RUT955 *7V***)?

Best regards,

by

Hi, 

I've now tested the newest stable Firmware RUT9_R_00.07.02.3. This is the first Firmware since 06.08.5 which upgrades just fine without deleting random settings and crashing the whole production.

It still did not solve the problem, i've run the Modem updater per your instructions, unfortunately it got stuck and the router crashed. Now the Mobile Interface is not shown anymore in the Webui. 

When i want to run the Modem updater to try it again i get an error:
 

root@XXXXXX:~# modem_updater -g

[ERROR] Not sure what flasher to use. Exiting..

Is there any chance to recover this Routers Modem now or is it now an RMA..?

Thanks
Pascal


 

by
Same problem

Update modem firmware doesn't help
0 votes
by

I've work a lot for understand this problem and found a solution.

Sms are sent through LTE when you are on 4g network.

You need to check the correct Apn for your operator and set it into section interface of the Gui.

Not all Apn allow to send Sms.

It is not enough that you are able to connect to internet.

For Tim correct apn is 'ibox.tim.it' and not the automatic set 'wap.tim.it'

Before set it, the problem was on this parameter that you can check only by CLI

>uci show simcard

Check parameter force_apn.

It must to be set as '-1'

It is not present into the gui but it very important and also sometimes this setting will be lost when you update firmware.

Set this by this command

>uci set simcard.@sim[0].force_apn='-1'

>uci commit

Then reboot

Check the apn and set it correctly into the interface section and everything will works good.

You can offer to me a beerlaugh