11426 questions

13616 answers

21347 comments

32049 members

0 votes
51 views 0 comments
by

Hi,

after updating my RUT240 to the latest FW today it seems that the pushed routes which are pushed by the OpenVPN Server are assined to the wrong GW / IF

LOG:

Thu Jun 30 19:19:30 2022 daemon.notice openvpn(Home)[20507]: net_route_v4_best_gw query: dst 0.0.0.0
Thu Jun 30 19:19:30 2022 daemon.notice openvpn(Home)[20507]: net_route_v4_best_gw result: via 0.0.0.0 dev wwan0
Thu Jun 30 19:19:30 2022 daemon.notice openvpn(Home)[20507]: TUN/TAP device tun_c_Home opened
Thu Jun 30 19:19:30 2022 daemon.notice openvpn(Home)[20507]: do_ifconfig, ipv4=1, ipv6=0
Thu Jun 30 19:19:30 2022 daemon.notice openvpn(Home)[20507]: net_iface_mtu_set: mtu 1500 for tun_c_Home
Thu Jun 30 19:19:30 2022 daemon.notice openvpn(Home)[20507]: net_iface_up: set tun_c_Home up
Thu Jun 30 19:19:30 2022 daemon.notice openvpn(Home)[20507]: net_addr_v4_add: 10.164.31.100/24 dev tun_c_Home
Thu Jun 30 19:19:30 2022 daemon.notice openvpn(Home)[20507]: /etc/openvpn/updown.sh tun_c_Home 1500 1545 10.164.31.100 255.255.255.0 init
Thu Jun 30 19:19:31 2022 daemon.notice openvpn(Home)[20507]: net_route_v4_add: 10.164.31.0/24 via 10.164.31.1 dev [NULL] table 0 metric -1
Thu Jun 30 19:19:31 2022 daemon.notice openvpn(Home)[20507]: net_route_v4_add: 10.164.200.0/24 via 10.164.31.1 dev [NULL] table 0 metric -1
Thu Jun 30 19:19:31 2022 daemon.notice openvpn(Home)[20507]: net_route_v4_add: 10.164.220.0/24 via 10.164.31.1 dev [NULL] table 0 metric -1
Thu Jun 30 19:19:31 2022 daemon.notice openvpn(Home)[20507]: net_route_v4_add: 10.164.254.0/24 via 10.164.31.1 dev [NULL] table 0 metric -1
Thu Jun 30 19:19:31 2022 daemon.notice openvpn(Home)[20507]: net_route_v4_add: 10.164.222.0/24 via 10.164.31.1 dev [NULL] table 0 metric -1
Thu Jun 30 19:19:31 2022 daemon.notice openvpn(Home)[20507]: net_route_v4_add: 10.164.240.0/24 via 10.164.31.1 dev [NULL] table 0 metric -1
Thu Jun 30 19:19:31 2022 daemon.notice openvpn(Home)[20507]: net_route_v4_add: 10.164.221.0/24 via 10.164.31.1 dev [NULL] table 0 metric -1
Thu Jun 30 19:19:31 2022 daemon.notice openvpn(Home)[20507]: net_route_v4_add: 10.164.30.0/24 via 10.164.31.1 dev [NULL] table 0 metric -1
Thu Jun 30 19:19:31 2022 daemon.notice openvpn(Home)[20507]: Initialization Sequence Completed



and the routing table shows

Network     Target     IPV4-Gateway     Metric     Table
(wwan0)     0.0.0.0/0     *     0     wan
(wwan0)     0.0.0.0/0     *     1     main
(wwan0)     10.164.30.0/24     10.164.31.1     0     main
(tun_c_Home)     10.164.31.0/24     10.164.31.1     0     main
(wwan0)     10.164.200.0/24     10.164.31.1     0     main
lan     10.164.203.0/24     *     0     main
lan_Guest     10.164.204.0/24     *     0     main
(wwan0)     10.164.220.0/24     10.164.31.1     0     main
(wwan0)     10.164.221.0/24     10.164.31.1     0     main
(wwan0)     10.164.222.0/24     10.164.31.1     0     main
(wwan0)     10.164.240.0/24     10.164.31.1     0     main
(wwan0)     10.164.254.0/24     10.164.31.1     0     main



also a traceroute shows that the packaged are routed to the wwan0 IF.... Also deleting the tunnel, and recreating it was not helpfull.

does anybody has an idea?

1 Answer

0 votes
by
short update....

I just updated also my RUTx11 and I can see the same error there....