subscribe to our Youtube


11981 questions

14261 answers


35629 members

0 votes
160 views 2 comments


I am using firmware version RUT36X_R_00.07.01.2 but I would like to upgrade to the latest version (I have had some problems with Carrier Aggregation that may or may not get fixed by an update).

I haven't tried RUT36X_R_00.07.02.2 yet, but I've tried every other firmware inbetween and each time I lose my connection to EE (in the UK) and I cannot get it back - I just get data connection not connected, and nothing I do brings it back.  Even with a reset to original settings.  Eventually I give up and revert back to RUT36X_R_00.07.01.2 which immediately just works.

Before I go through the same procedure with the newest firmware RUT36X_R_00.07.02.2, has anyone else had the same problem, and if so what was their experience?

Is there anything in RUT36X_R_00.07.02.2 that was known to cause this problem, and has it been fixed?

Thank you!

1 Answer

0 votes


I would suggest you to update your device's modem firmware. Before attempting the update, you need to have your device updated to at least RUT36X_R_00.07.02 firmware version and have the router connected to a different WAN source, either wired or wireless. Below are the instructions:

  • Access your device via SSH and execute the following commands:
    • opkg update
    • opkg install modem_updater
    • opkg install sshfs
    • modem_updater -g
  • The last command will list available firmware versions. Next modify the following command:
    • modem_updater -i <ID> -v <VERSION>
      • <ID> - you can try 1-1, however, in case of an error you should be shown a correct ID.
      • <VERSION> - enter the latest firmware version from the list of the previously executed command.

Best regards,


Thank you Žygimantas for your quick answer, but I have no easy way to get the router to connect to a different WAN source and I do not know how to SSH into the router.

Also, I am extremely concerned that if I update to the latest modem firmware and that doesn't work, I will really struggle to get back to a working version.

Please can you confirm something for me: Does this mean that the modem firmware is never automatically updated, and that this is the only way to do it?  It seems very strange that I could have two incompatible firmware versions on the same device.

Updating firmware is something that I am used to having to do, but SSH-ing into the router does not seem like something you should be recommending to your customers.  Does this mean I am stuck with a device that cannot be updated now?

I had a similar issue with my RutX11 (worked fine for a long time, upgraded firmware and stopped working).  I finally got it working and I had to do this (steps might be different due to it being a different device).

  1. I did upgrade my firmware and modem firmware as above, but I don't think that was the solution.
  2. I set my APN as per here.
  3. I went to Network -> Interfaces and clicked the pencil icon on my MOB1S1A1 interface (my SIM card)
  4. I set the APN Information
  5. I set PDP Type to IPv4.
I believe step 5 is what is needed.  I have sense set it to IP6 or IP4/IP6 and each time the Data Connection State will go to Disconnected.  It only toggles to Connected when I select IPv4 for PDP Type.