11384 questions

13563 answers

21250 comments

31888 members

0 votes
149 views 6 comments
by

Hi, I am trying to get a new RUT951 (FW version RUT9M_R_00.07.02.3) up on LTE as the only WAN connection, using sim 1.
I get as far as where I can observe that the 4g connection is ok, but the wwan0 network interface is not coming up:

uqmi -d /dev/cdc-wdm0 --get-current-settings
{
       "pdp-type": "ipv4",
       "ip-family": "ipv4",
       "mtu": 1500,
       "ipv4": {
               "ip": "10.60.245.197",
               "dns1": "193.213.112.4",
               "dns2": "130.67.15.198",
               "gateway": "10.60.245.198",
               "subnet": "255.255.255.252"
       },
       "ipv6": {

       },
       "domain-names": {

       }
}

If I now go ahead and configure it manually, it seems to work (for a short while until the autmation takes over and fails again):

ip addr add 10.60.245.197/32 brd 255.255.255.255 dev wwan0
ip link set wwan0 up
ip route add default dev wwan0 proto static scope link src 10.60.245.197 metric 3

ping 8.8.8.8

PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=54 time=55.390 ms
64 bytes from 8.8.8.8: seq=1 ttl=54 time=55.038 ms
^C


I see the following from mob1s1a1 in the log:

Starting network mob1s1a1 using APN <my apn>
cid4: 7
uqmi -d "/dev/cdc-wdm0" --timeout 3000 --set-ip-family ipv4 --set-client-id wds,"7"
uqmi -d "/dev/cdc-wdm0" --timeout 3000 --set-client-id wds,"7" --start-network --profile 1
pdh4: "No effect"
Unable to connect IPv4
Releasing client-id 7 on /dev/cdc-wdm0
Failed to create IPV4 connection
Stopping network mob1s1a1
Command failed: Not found
Command failed: Not found
Command failed: Permission denied

so it appears something is going wrong in some script somewhere but I have not been able to figure out where.

I have been able to update a RUT950 from fw version 06.08.5 (which we have a lot of) to the same firmware version and get it online on 4g with similar settings.

Any hints as to what goes wrong appreciated!

1 Answer

0 votes
by

Hello,

Thank you for contacting us.

I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration > Troubleshoot section and download troubleshoot file from there.

Best regards,

Žygimantas

 

by
Working on it - the troubleshooter function by default bundled that router's VPN certificates since I am using the inline OpenVPN config format. Maybe it is better to filter/garble at least the private key section before creating the tarball?

Uploaded troubleshooting now.

This was the result of a clean factory reset from the GUI + a configuration run from our ansible setup, but leaving out the final vpn configuration steps
by

Hello,

Make sure you are using a correct APN. You can also try Auto APN option in Network -> Interfaces -> <Your_mobile_interface_settings>.

Check if your provider does not require you to have VoLTE enabled. You can enable it in Network -> Mobile -> General section.

If the above are correct, I would like you to update your device's modem firmware. Before attempting the update, you need to connect your router a different WAN source, either wired or wireless. Below are the the instructions:

  • Access your device via SSH and execute the following commands:
    • opkg update
    • opkg install modem_updater
    • opkg install sshfs
    • modem_updater -g
  • The last command will list available firmware versions. Next modify the following command:
    • modem_updater -i <ID> -v <VERSION>
      • <ID> - should be 1-1, however, in case of an error you should be shown a correct ID.
      • <VERSION> - enter the latest firmware version from the list of the previously executed command, it should be EC25ECGAR06A12.

Best regards,

Žygimantas

by

Thanks for the feedback - unfortunately it does not appear to have solved the problem:

I first tested with volte enabled (no difference)
and then updated the modem firmware according to your instructions. There was a choice between  version


root@nmtest:~# modem_updater -g

Available versions:
...
EC25ECGAR06A12M1G
EC25ECGAR06A12M1G_BETA

I chose the non-beta version.
After the update and reboot, I still see no WAN link coming up automatically, and I am still able to configure it manually and ping out via mobile until automation kicks in again,suggesting to me that there's something with the script logic rather than the mobile interface?

by
I would like you to generate another troubleshoot file with new modem firmware. I will forward it to the RnD to check.

Best regards,
by
Seems I had to delete the old file to upload a new - just done that now.
by
I tried upgrading to RUT9_R_00.07.02.5 today - still no mobile connection - any news on this?