FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
296 views 1 comments
by anonymous

Hi Teltonika team

SIM Card are inserted and are working and on other modems the aswer are corrct!! I think this are a problem on this modem..

Please let me know

BR,

Marcello

The post on the post are:

http://172.16.12.1/ubus

    "jsonrpc""2.0",

    "id"138,

    "method""call",

    "params": [

        "xxxxxxxxx",

        "vuci.network.mobile",

        "mobile_info",

        {

            "modem""1-1.4"

        }

    ]

}

Answer are:

{

  "jsonrpc": "2.0",

  "id": 138,

  "result": [0, {

    "mobile": {

      "imsi": "-",

      "rsrp": "-",

      "sim": "-",

      "cellid": "-",

      "rscp": "-",

      "recv": "-",

      "band": "-",

      "ecio": "-",

      "sinr": "-",

      "netstate": "-",

      "operator": "-",

      "state": "-",

      "sent": "-",

      "rsrq": "-",

      "iccid": "-",

      "conntype": "-",

      "imei": "-",

      "signal": "-"

    }

  }]

}

by anonymous

the answer from the RUT955 ist:

{
    "jsonrpc""2.0",
    "id"138,
    "result": [
        0,
        {
            "mobile": {
                "imsi""228021506538074\r\n",
                "rsrp""-95\n",
                "sim""inserted\n",
                "cellid""20786954\n",
                "rscp""service mode not supported\n",
                "recv""29955742",
                "band""LTE BAND 7\n",
                "ecio""service mode not supported\n",
                "sinr""5.9\n",
                "sc_band_av""Single",
                "netstate""registered (home)\n",
                "operator""Sunrise\n",
                "state""Connected\n",
                "slot""SIM 1",
                "sent""29957843",
                "rsrq""-9.0\n",
                "iccid""89410201714400679690\n",
                "conntype""4G (LTE)",
                "imei""865546044841191\r\n",
                "signal""-65\n"
            }
        }
    ]
}

2 Answers

0 votes
by anonymous

Hello Marcello007,

You will need to specify the correct modem id for the information. You can find the modem id using the following command: 

cat /etc/config/network | grep modem

Replace 1-1.4 with the correct value 

  {

            "modem""1-1.4

}

This should give the information to your JSON request.

Regards,

Shivang 

0 votes
by anonymous

Hi Marcello,

Probably what happened is that the linux driver assigned another number to the Quectel modem, so instead of  "modem""1-1.4" it can be "modem""1-1.2" for example. 

To find out the modem number, you can use the command "uci show simcard" or use the following JSON-RPC.

{    
"jsonrpc": "2.0", "id": 1, "method": "call", "params": 
    [
        "{{ubus_key}}", "uci", "get",
        {
            "config":"simcard"
        }
    ]
}

After getting to know whats the modem number, you can change it on your JSON-RPC request and get the data you want.

Another option, is using the gsmctl commands, so you can get data directly from the modem, more about that in this article

Best regards.