FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12072 questions

14365 answers

22633 comments

36186 members

0 votes
122 views 1 comments
by

Hello, 

I'm trying to use the blacklist/whitelist feature for operator, but it does not work.

To do this, I execute the following commands :

  • Enabling whitelist/blacklist mode : 
    • uci set operctl.general.operlist='1' 
    • uci commit 
    • luci-reload
  • Set the mode "blacklist" : 
    • uci set operctl.general.mode='blacklist' 
    • uci commit 
    • luci-reload
  • Add an operator :
    • uci add operctl list 
    • uci set operctl.@list[1].name=Orange 
    • uci set operctl.@list[1].code=20801
    • uci commit luci-reload

If afterwards I check that my operator is indeed present in the operctl and if the mode is correct with "list uci show operctl", all is fine.

But it is still possible to connect to the operators in this list.

If I add the operator to which the device is currently connected, nothing happens.

I would like to know if I am doing something wrong ?

I also tested via the teltonika HMI, and I have the impression that it does not work either.

For info, I'm on Teltonika-RUT950

1 Answer

0 votes
by

Hello,

The commands you are using may be incorrect.

These are dependent on the device and firmware used. You can read more about uci usage here. Is there any reason why you want to set this via CLI, instead of using WebUI interface, as, in case you are writing some script, it would be useful to have one device configured via web interface first, and see the options that appear in the CLI configuration.

Also, which firmware are you using, as luci-reload is not used since 7.0 and above versions. Instead, services are reloaded by entering /etc/init.d/<service_name> restart. In operctl case, simply uci commit should be sufficient. 

I have tested your scenario and the following commands worked on RUT955 with RUT9_R_00.07.02.3 firmware:

  • uci add operctl operlist
  • uci set operctl.@operlist[0].name='Orange'
  • uci set operctl.@operlist[0].mcc_mnc='20801'
  • uci set simcard.@sim[0].opermode='blacklist'
  • uci set simcard.@sim[0].operlist_name='Orange'
  • uci set simcard.@sim[0].operlist='1'
  • uci commit
  • /etc/init.d/simcard restart

Regarding the provider of the SIM card that is currently inserted in your device, your SIM card provider will not be blocked even if blacklisted by default.

Best regards,

Žygimantas

by
Hello,
First, thank you for your answer.

To answer your questions, we actually need to use these commands via CLI.

The firmware we use is RUT9XX_R_00.06.07, the feature may not work on this version? Do you advise us to change the version ?

Regarding the last remark on the sim card provider, we tried to block all operators, without success.