11384 questions

13563 answers

21250 comments

31888 members

0 votes
107 views 7 comments
by

I have an RUTX11 on my yacht and this weekend traveled from UK to the channel islands (Gurnsey).

On teh trip over we had good coverage many miles of the UK coast and French coast. Picked up several mobile providers on our way past France. However as soon as we entered Gurnsey, no data via the mobile. I had a Vodafone SIM and 3 SIM in the system, both allowing roaming. Several Vodafone SIM cards on various devices onboard connected without a problem. I could not get the RUTX11 to connect.

As soon as we left and could get a French signal it reconnected and worked fine. I am unable to find out why neither of teh SIM cards would work. I could not find much information on debugging.

I did download the trouble shooting file and take a look through the logs, nothing obvious. Except in the system log I did get a fair number of these.

Sat Jul  9 21:06:52 2022 daemon.info unhandler[2976]: gsm send: AT+QICSGPEH=1

Sat Jul  9 21:06:52 2022 daemon.info unhandler[2976]: gsm get: `ERROR`

Any ideas?

2 Answers

0 votes
by
Good morning,

Is it possible for you to send troubleshoot file by private message. It would help us more as we could see all gsm and system logs.

Sincerely,
E.G.
by
It's a pitty you guys never update the answer here with the resolution of the problem. It's always hidden in DM. Would be nice to learn something from the forum.
0 votes
by

Weird. Guernsey is part of the UK's mobile system, so roaming won't do you any good. They use PLMN 234xx there as well, so you won't be able to roam onto other 'UK' operators, unless there is some special romaing contract in place.

Next time an operator scan would at least give you information on what operators this modem sees. Either from the UI, or otherwise from the command line: gsmctl --at 'AT+COPS=?' . It will take a few minutes and then show you a list of operators. On the command line, take note of the 5 digit numbers like 23455 (Sure Guernsey).

by
Just pulled the VF SIM and put it in another device. Instantly connected to Airtel-Vodafone at 4G and gave me data. Seems something is really a miss with the RUTX-11
by

The operator scan in the guy is flakey in 7.xx.y indeed. On the command line it works (it directly sends a command to the modem). If you get 'ERROR' resonse, just try again. The modem might be busy.

To get to the command line from a Windows laptop you can use putty (from www.putty.org) and login as admin + your pw. Macos has ssh in Terminal or otherwise use the Mac port of putty.

by

I have run the command and this is the output.

root@Olaso-Gateway:~# gsmctl --at "AT+COPS=?"

+COPS: (1,"3 UK","3 UK","23420",2),(1,"Orange F","Orange","20801",7),(1,"F-Bouygues Telecom","BYTEL","20820",7),(1,"F SFR","SFR","20810",2),(1,"Free","Free","20815",7),(1,"Airtel-Vodafone","ATL-VOD","23403",7),(1,"Airtel-Vodafone","ATL-VOD","23403",2),(1,"JT","JT","23450",7),(1,"Sure","Sure","23455",7),(1,"JT","JT","23450",2),(1,"Sure","Sure","23455",2),(1,"vodafone UK","voda UK","23415",2),(1,"EE","EE","23430",2),(1,"O2 - UK","O2 - UK","23410",2),(1,"208 16","208 16","20816",7),,(0-4),(0-2)

Am having real issues in Alderney, Braye Harbour. Occasionally I can lock onto F SFR and then that drops and I have loads of problems. Have not found a way to force it back onto F SFR. Even setting the operator through force operator by setting operator connection to manual and selecting one. I do see us occasionally see it connect for a few seconds to Airtel-Vodafone.

Something very strange is going on with regards to selecting and locking onto an operator.

by

I don't have an answer, just an opinion on this:

A) I am not very impressed with French operators. Connectivity is varying a lot between masts and operators.

B) It looks like most entries are for WCDMA (3G [2]), not LTE ([7]). Did you limit the modems to 4G (LTE) only? (*)

I would suggest you contact support for both SIMs and ask them what to expect in Gurnsey

(*) 4G is a misnomer. 4G and LTE are not the same thing. WCDMA+HSPA/HSUPA/HSOPA is called '4G' by many operators. LTE is a completely different technology than WCDMA+... .

Hopefully this is of any help. Strange it is indeed.

by

Thanks. I have tried a number of things, forcing the operator, setting LTE only, setting auto. For a period of almost 24 hours I had rock solid "S SFR" connectivity, and now can't lock onto any operator. I do see the system locking on for a few seconds (Airtel-Vodafone and Sure), but never getting any "Data connection state", then it stops and tries SIM2.

It looks like it will be something simple in the end.

by

Following a complete power cycle it is cycling through this. So just never connects.