FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12615 questions

14984 answers

23964 comments

46769 members

0 votes
148 views 0 comments
by

I cannot access the web interface remotely unless I manually stop the firewall from the command shell.  Seems identical to the problem in this thread:  
 https://community.teltonika-networks.com/12853/rut950-access-to-web-ui-not-working

I am having this problem on three Rut240 routers. There were no configuration changes before this started to happen.

I can access with remote ssh

I only have remote access to the router, so factory reset not an option.   I have tried many configuration changes in the  firewall and uhttp config files.  Changed ports, made sure they match between uhttp and firewall configureaton. Everything looks enabled and option _httpWanAccess '1' 

I have tried accessing from different locations (different IP). Tried accessing from 4G phone as well.  Tried rebooting a few times and many other experiments,  Listeners to ports are fine and the uhttp process is running fine

I know now it is a firewall problem as I noticed I can access without any problems when I stop the firewall process.  But it is inconvenient to need that approach both because of security risk and firewall rules like port forwarding which I use.  Have there been any solutions found for this issue other than factory reset.

1 Answer

0 votes
by

Hi,

Have you checked if the HTTP and HTTPS ports are open?
If your router has a public IP, please check the ports 80 and 443 whether open or not via the below link:
https://ping.eu/port-chk/

Try to analyze firewall rules, and see if there is any rule already sitting there which is preventing HTTP and HTTPS ports to open.
Try to restart the router's firewall with the below command:
/etc/init.d/firewall restart
Try to restart the router's web server with the below command:
/etc/init.d/uhttpd restart

Please send me the troubleshoot file via Private message. A Troubleshoot file contains a device's event logs, configuration files and other info useful for diagnostics. It can be downloaded from your device's WebUI, Troubleshoot page:

System → Administration → Troubleshoot

Regards,
Ramandeep