subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
671 views 5 comments
by anonymous

What kind of throughput should I expect with Zerotier + RUT240?

Firmware is 7.2.2.

"Normal" NATed throughput to internet is 85-100Mbps.

If I run iperf3 to server in DC over Zerotier I am getting 3-3.5Mbps and /usr/bin/zerotier-one is using about 85% CPU.

1 Answer

0 votes
by anonymous

Hi Gilbert,

There could be many reasons for the slower speed of ZeroTier VPN tunnels. Zerotier traffic goes through the ZeroTier network and if there are no Zeriotier root servers nearby, you will get a slower speed. Also, Double NAT reduces the speed to some extent as well.

Related to CPU usage, please go to CLI and check which process is consuming more CPU. You can use the command top to check for CPU usage by each process. For me the result was as below:


by anonymous

> Related to CPU usage, please go to CLI and check which process is consuming more CPU.

Like I said, it's the zerotier-one process.

From zerotier-cli peers I can see that the connection between the two peers I am testing is DIRECT. Ping time between them is 15ms at idle.

> For me the result was as below:

What kind of throughput were you getting when Zerotier is using 1% CPU?

by anonymous

RUTXR1, 40% CPU usage when running iperf3 from a client node, ~20Mbps throughput. Not quite the increase in throughput I had hoped for over the RUT240. I assume this only uses one core.

I even tried getting rid of the WAN entirely and tested between LAN client on RUTXR1 and server plugged in to "WAN" of RUTXR1 and throughput is the same. So CPU seems to be the limiting factor here.

by anonymous

Hi Gilbert,

Would you please provide me troubleshoot file of the RUT240 device via Private message? I would like to replicate the same issue as you are facing. 
A Troubleshoot file contains a device's event logs, configuration files and other info useful for diagnostics. It can be downloaded from your device's WebUI, Troubleshoot page:
System → Administration → Troubleshoot

by anonymous

I don't think this is really a RutOS problem. Zerotier only uses one core, the CPU on the devices I have tested with isn't very fast, and they should be resolving this in version 2 of Zerotier.

Assuming it scales linearly from 20Mbps/1 core then RUTXR1 should be good for 80Mbps assuming all 4 cores in use at 100%.
by anonymous
Can you try to test it on different RUTX firmware versions, to see if anything changes?
For the starter, you can use 07.01.4 and later test it on 07.02.04. Make sure to wipe all configurations before proceeding to another firmware version.