FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
508 views 1 comments
by anonymous

Hi!

How to set RUT951 LAN ports/switch to work in 100M Full duplex or Half duplex or in 10M mode?

How to turn off auto negotiation on LAN ports?

Problem I have faced is - network link to specific device is not established. I cannot change network settings in this other device to establish connection.

1 Answer

0 votes
by anonymous

Hello,

Currently, due to router's hardware it is not possible to target separate ports, only different interfaces, meaning that configuration will apply to either all of the LAN ports (interface eth0) or WAN port (interface eth1).

For configuration, you will need to use package ethtool, which you can communicate with via CLI/SSH. You can enter command ethtool -h for more details on how to use ethtool.

Example commands may be:

  • ethtool -s eth0 speed 100 duplex full autoneg off
  • ethtool -s eth0 speed 10 duplex half autoneg off

Best regards,

Žygimantas

by anonymous

I tried solution you suggested -

root@Teltonika-RUT951:~# ethtool -s eth0 speed 10 duplex half autoneg off
output - Cannot get current device settings: No such device
not setting speed
not setting duplex
not setting autoneg

Settings are not set.

command uci show network output is - 

root@Teltonika-RUT951:~# uci show network

network.loopback=interface

network.loopback.ifname='lo'

network.loopback.proto='static'

network.loopback.ipaddr='127.0.0.1'

network.loopback.netmask='255.0.0.0'

network.globals=globals

network.globals.ula_prefix='fd0c:fc11:5117::/48'

network.lan=interface

network.lan.proto='static'

network.lan.macaddr='00:1e:42:59:e5:2b'

network.lan.netmask='255.255.255.0'

network.lan.ip6assign='60'

network.lan.ipaddr='192.168.2.1'

network.lan.disabled='0'

network.lan.metric='1'

network.lan.type='bridge'

network.lan.stp='0'

network.lan.ifname='eth0 eth0.1'

network.lan_eth0_1_dev=device

network.lan_eth0_1_dev.name='eth0.1'

network.lan_eth0_1_dev.macaddr='00:1e:42:59:e5:2b'

network.wan=interface

network.wan.ifname='eth0.2'

network.wan.proto='dhcp'

network.wan.macaddr='00:1e:42:59:e5:2c'

network.wan.disabled='0'

network.wan.metric='2'

network.wan_eth0_2_dev=device

network.wan_eth0_2_dev.name='eth0.2'

network.wan_eth0_2_dev.macaddr='00:1e:42:59:e5:2c'

network.wan6=interface

network.wan6.ifname='eth0.2'

network.wan6.proto='dhcpv6'

network.wan6.disabled='0'

network.wan6.metric='3'

network.@switch[0]=switch

network.@switch[0].name='switch0'

network.@switch[0].reset='1'

network.@switch[0].enable_vlan='1'

network.@switch_vlan[0]=switch_vlan

network.@switch_vlan[0].device='switch0'

network.@switch_vlan[0].vlan='1'

network.@switch_vlan[0].ports='0 1 2 6t'

network.@switch_vlan[1]=switch_vlan

network.@switch_vlan[1].device='switch0'

network.@switch_vlan[1].vlan='2'

network.@switch_vlan[1].ports='4 6t'

network.mob1s1a1=interface

network.mob1s1a1.proto='wwan'

network.mob1s1a1.modem='1-1'

network.mob1s1a1.sim='1'

network.mob1s1a1.pdp='1'

network.mob1s1a1.auth='none'

network.mob1s1a1.apn='internet.lmt.lv'

network.mob1s1a1.disabled='0'

network.mob1s1a1.metric='4'

network.mob1s2a1=interface

network.mob1s2a1.proto='wwan'

network.mob1s2a1.modem='1-1'

network.mob1s2a1.sim='2'

network.mob1s2a1.pdp='1'

network.mob1s2a1.disabled='0'

network.mob1s2a1.metric='5'

Interfaces are bridged.
What is correct command in my case? 
10M link for all interfaces are ok in my case.