subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
245 views 2 comments
by anonymous
Following an update to 6.09.02 the rut950 worked for about a day then stopped, when I tried to reconnect it takes me directly to the update page. I have tried to reapply the update but it says updating and that's it choose how long I leave it, If I go back its exactly the same, yes its been powered off several times since.

I was going to try the bootloader upgrade but cant find a download location

RUT950  1010M1  Batch no 0011   HW rev   0505

1 Answer

0 votes
by anonymous

Hello, this is Martín, Tech Support Engineer for Teltonika Networks.

To recover your device you can perform a Bootloader Upgrade with the following files.
Please be aware that in order to recover your device correctly, you will first need to upgrade the device to the Legacy Version (RUT9XX_R_00.06.09.2) and then you will be able to upgrade to the most recent Firmware (RUT9_R_00.07.02.3) from the WebUI.
I have linked the instructions to perform the upgrade to the Latest Firmware from the Legacy Firmware.

Best regards.

by anonymous
thankyou for your response, when I select the fw version you mentioned the upload is confirmed and the update starts, lan lights flash sequentially, after a period of time it goes back to all 4 lan lights flashing simultaneously and im back where i started gives firmware update page gives firmware update page gives bootloader update page
by anonymous


Do you still have SSH access to the device? If so, you could try performing a Firmware Upgrade through CLI.

I remain attentive to any further comments.
Best regards.