FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
637 views 8 comments
by anonymous
Hi,
we're having a Vodafone M2M-Sim in Germany which is capable for roaming in German Telekom and O2 network. However it prefers Vodafone connections, even if it's only 2G. Therefore were forcing the modem sometimes in Telekom or O2 networks by setting the operator code manually.
However sometimes we have to do this by remote, with trial and error. So if we force it into Telekom networks and it isn't available on site, the remote connection is lost.
That's why we want to work with Connection mode Manual-auto. So we put in operator code  for Telekom/O2 and if it fails to connect we want it to fall back to Vodafone.

This functionality doesn't work for us. I tested it with the lastest Fw 7.2.3 and legacy 6.9.2

For testing purposes i entered a non-existing operator-id (123456). However it never switches back to Vodafone. Please see screenshots attached.
How can i fix this?

Edit: Troubleshoot file attached
Edit 2: Troubleshoot file with new modem firmware added (troubleshoot-Teltonika-RUT955.com-2022-08-02.tar.gz)

1 Answer

0 votes
by anonymous

Hello,

I was unable to reproduce your issue thus, I would like you to attach a troubleshoot file to your question or send it to me in a personal message. Please, replicate the issue, then access router's WebUI, go to System -> Administration > Troubleshoot section and download troubleshoot file from there.

Best regards,

by anonymous
Hi,
I attached the troubleshoot file to my original post.
by anonymous

The logs show that modem loops on command COPS?, which is responsible for selecting operators.

I would like you to try to update your device's modem firmware. Before attempting the update, you need to connect your router to a different WAN source, either wired or wireless. Below are the the instructions:

  • Access your device via SSH and execute the following commands:

  • opkg update
  • opkg install modem_updater
  • opkg install sshfs
  • modem_updater -g

  • The last command will list available firmware versions. Next modify the following command:

  • modem_updater -i <ID> -v <VERSION>

  • <ID> - should be 1-1.4, however, in case of an error you should be shown a correct ID.

  • <VERSION> - enter the latest firmware version from the list of the previously executed command, which should be EC25EUGAR08A01M4G.

Best regards,

by anonymous
Hi,
I updated to the modem firmware you mentioned. The problem remains the same.
I added the troubleshoot file to the main post.

Regards,

Stefan
by anonymous
Hello,

any update on this issue?

Best regards
by anonymous
The issue regarding manual-auto setting should be solved with the 7.2.7 firmware release.
by anonymous

A new firmware has been released, with improvements regarding manual - auto connection mode. You can download it here and check if that solves your issue. 

by anonymous

Hi,

I can confirm that the behaviour of the modem changed. The modem registers for a short periode of time with Deutsche Telekom provider. However the connection isn't established for a long enough time. After some seconds it looks like the connection is cancelled by the modem. 

If I enter the operator code of Telekom in manual mode it all works just fine.

A Data connection can't be started and and no data is transfered.

I uploaded the troubleshoot file to the main post.

 

manual set to telekom.de:

by anonymous
Hi,

any updates on this issue?