7953 questions

9404 answers

15104 comments

12982 members

0 votes
3,062 views 4 comments
by
I am on EE network and had one of their mini WiFi hub 4G routers. Indoor use only, USB powered, internal antenna.

I have replaced this with a RUT240 to allow me to get a better signal by plaing one of the external antenna outside and higher up.

However, while the EE device gives me around 10M down and 1M up (very weak signal here) the RUT 240 which should do much better is only giving me < 1M down and 1M up.

I've upgraded to the latest firmware, tried with one antenna and two and the performance is the same.

Any thoughts on why this might be please?

Thanks,

Bernie
by
I have the same issue. On 3, have better router performance in both speed and coverage on the free Huawei modem I got with the contract.

Assumed I’d get better service with the 240 and a good external aerial, doesn’t seem to be the case.

Thanks in advance for your help.

4 Answers

0 votes
by

Hello,

There is new RUT240 firmware available, in which this issue is resolved. You can download latest RUT240 firmware from here:

https://wiki.teltonika.lt/view/RUT2xx_Firmware

Best answer
0 votes
by
Hello,

Are you sure that RUT240 is connected to 4G network ?

I've sent you a PM with the test FW version, could you let me know if this helps for you ?
by
Thanks, - yes I'm definitely on 4G. Will install the dev firmware and give it another try.

Thanks,

Bernie
0 votes
by
I sent mine back for a refund as even the dev release of the firmware didn't make a significant difference.

I did also speak to a reseller who suggested that EE had made some recent network changes that might explain it but if I pay over £100 for a commercial 4G router I do expect it to work better than the free device supplied by EE that only has internal antennae.

Regards,

Bernie
by
Thanks for your thoughts Bernie. I’m hoping I can get better results out of it somehow as I need to link it up with access points and think I’ll struggle with the Huawei box 3 supplied??

That said, I’ve given up for now with the 240 and am using it, the speed is better than I can get with the 240 and 80 quids worth of external aerial. Shame the router side is a bit rubbish!
0 votes
by
Have you checked if both EE router and RUT240 uses same LTE band, when you are doing speedtest ?
by
Doing the speed tests at the same time..... the cheap Chinese one performs better every time. Shame, but I think I’ll have to send this one back.