11384 questions

13563 answers

21250 comments

31888 members

0 votes
110 views 3 comments
by

Troubleshoot file

Hi!

I've had problems with modem disconnection from LTE+ with my RUTX12 HW rev 0303. Sometimes it works for weeks but when it start to drop connection and then reconnect it can be like that for days, been the same with different firmware revisions, now I',m om latest 07.02.4.

I've seen other here with the same problem and the advice was always to update modem firmware, mine was at nnn4nn with the latest being EG06ELAR04A08M4G and that was the one I installed after seeing several posts. It said successful after modem 2 and then 1 but the modems didn't restart (no led blinking or anything) so after 30 minutes I rebooted the router and then - no more modems. Can't find anything but MOB1S1A1 & 2 (Stopped).

I finally made a restore to factory defaults and now the indicators for strength are blinking over the two SIM slots, but still no modems, no go.

Is there anything I can do? Modem_updater won't even find the modems...

1 Answer

0 votes
by

Hello,

I would recommend starting by reflashing the router using the bootloader menu and try to see if this helps.

Also, try to check if there are any ttyUSB* available from CLI in /dev/ folder. If there are none, then most likely the modems became unreachable and there is not much to do to recover them other than trying to short some pins on the modem itself but it is not recommended.

If the bootloader procedure does not help you, I would recommend contacting your point of sale and send the device in for RMA.

by

Thank you! Only thing I find in /dev is

tty

ttyMSM0

ttyS0

ttyS1

Should I trybootloader procedure anyway you think? I can do that when I'm back home where I have computers with Ethernet, but fortunately I will receive a brand new RUTX14 today so hopefully that till work as expected!

by
Hello,

Yes, I would recommend trying the bootloader procedure anyways, maybe that would be enough to bring the modems back.

As the global RMA rate of our devices is only 0.05% of all devices manufactured, I would be highly positive, that the RUTX14 ordered will have no issues whatsoever. However, this percentage also means that some devices being faulty is not inevitable as we sell hundreds of thousands of devices worldwide and this can happen due to some faulty component on the device PCB. We are always happy to solve any hardware-related issues as fast as possible and our RMA is usually quite fast.
by
Hi again! I tried the bootloader but no difference, no modems found. The warranty was expired ten days ago so the seller wont accept to fix it under warranty... Do you have a how to as how to reset the modems by shortening the pins? I could at least try before I recycle it. Too bad.