subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
530 views 4 comments
by anonymous

On RUT955 with firmware RUT9_R_00.07.02.3, custom firewall rules doesn't work only after reboot and loses connectivity with the Site PLC. However the same custom firewall rules works when the firewall rules are resaved after every reboot. The firewall rule is as follows :

iptables -A INPUT -p tcp --dport 1883 -s 192.168.x.x-j ACCEPT

iptables -A INPUT -p tcp --dport 1883 -s 10.x.x.x -j ACCEPT

iptables -A INPUT -p tcp --dport 1883 -j DROP

Could someone point out the issue and applicable fix?

1 Answer

0 votes
by anonymous


Iptables rules are temporarily saved by OpenWRT. After each firewall restart/router reboot, iptables rules get cleared. 
So to resolve this issue, you need to save iptables rules using the Custom rules option on the WebUI of the device. Navigate to WebUI, Network → Firewall → Custom Rules page. You can simply copy the same iptables commands and after each reboot, they will be added all over again. 

Please follow the below link for more information:


by anonymous

Hi Raman,

Thanks for the Reply, the issue I'm facing is with the Custom rules defined in WebUI, Network → Firewall → Custom Rules page. The Custom rules already defined here are not getting executed after the reboot. This needs to be saved every time after reboot to execute. I understand the following note,  "Custom rules are not recommended to be used with hostnames. The rules will not remain active after reboot due to security reasons". The implementation doesn't have any host names as well.

by anonymous


Would you please upgrade your device's firmware to the latest RUTOS RUT9_R_00.07.02.04?
To upgrade firmware, go to WebUI and navigate to the System->Firmware page and Turn off the "Keep settings" options ( this will erase previous configurations and will install firmware as fresh with default configurations. To download the firmware file, please visit the below link:
Afterwards, apply these rules on the customs rules page and save them. Test them with a restart.


by anonymous


I have updated the firmware to latest RUTOS RUT9_R_00.07.02.04 and installed them as fresh ones erasing the previous configurations via turning off the "Keep settings". I completely reconfigured the device and added custom firewall rules. 

But the issue remains the same, custom rules are not executing after the device reboot. The custom rules needs to be saved everytime after reboot to execute. Is there a work around to this issue.?

by anonymous
Hi Berdinson,

Please send the troubleshoot file to me via private message. To download troubleshoot file, go to WebUI and navigate to System->Administration->Troubleshoot. Click on generate button to download the troubleshoot file.