FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
608 views 4 comments
by anonymous

My RUT955 is giving no output either in the UI or via NMEA TCP. Wifi region has been set to UK (where we operate)

root@Teltonika-RUT955:~# gpsctl -sixp
0
0.000000
0.000000
0

root@Teltonika-RUT955:~# cat /dev/gps
$GNGNS,,,,,,NNN,,,,,,*1D
$GPVTG,,T,,M,,N,,K,N*2C
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
$GNGSA,A,1,,,,,,,,,,,,,,,*00
$GPGGA,,,,,,0,,,,,,,,*66
$GPRMC,,V,,,,,,,,,,N*53

Device > Teltonika RUT955 LTE
F/w> RUT9XX_R_00.06.09.2

2 Answers

0 votes
by anonymous
Probably a silly question, but......  have you enabled the GPS Service and set it to use the GGA sentences that you need?  I don't think that the setting for Wifi will have any bearing on the GPS function, the two aren't related.
by anonymous
Yup, GPS is enabled, as are the sentances on NMEA forwarder. Not sure of any other option to enable GGA?
0 votes
by anonymous

Hi,

  • Would you please confirm if you have the GPS antenna placed somewhere indoor location or an outdoor location? If it's in an indoor location, please move the antenna somewhere outdoor location. Make sure that the antenna can face the sky clearly. Give some time for the antenna to catch satellite signals about like 5-10 minutes.
  • Make sure that your GPS antenna is properly attached to the device and is not broken.
  • Please confirm if you have enabled Satellite configurations such as Galileo NMEA support, Glonass NMEA support and BeiDou NMEA support as well.
  • Try enabling all NMEA sentences and see if you can receive any data from any of the sentences.
  • Try restarting the GPS service on the device itself with the below command on CLI:
    /etc/init.d/gspd restart
  • Try to upgrade to the latest RUTOS 00.07.02.4 firmware version. To upgrade, go to WebUI and navigate to the System->Firmware page. There turn off/uncheck the "Keep settings" option and upgrade the 00.07.02.4 using the file. 
    Keep in mind, that turning off the "Keep settings" option will erase everything on a firmware upgrade to default settings.
    To download firmware, please visit the link below: https://wiki.teltonika-networks.com/view/RUT955_Firmware_Downloads

    Regards,
    Ramandeep
by anonymous
HI Raman

I have updated to 7.02.4 and now get the slightly more helpful "no gps signal" flash up when I go to the map screen. I am using an external antenna. This unit is not at home but on a remote boat, I will be down mid next week so will triple check the connections in case it's that
by anonymous
Hi,

Sure! test it outdoor somewhere and let us know the results.
An external antenna that you are using can you provide more details about it such as its brand and model number and link to the vendor's site?
Put the antenna module out where it can face directly to the sky.
by anonymous

I too am not seeing a GPS signal on a RUT955 with FW 00.07.02.7

I tried to do the suggested restart:

/etc/init.d/gspd restart and was told there is no such file...
with some sleuthing I determined that gpsd was more correct

root@Teltonika-RUT955:~#  /etc/init.d/gpsd restart

ls: /sys/bus/usb/devices/1-1.4/1-1.4/tty/tty?*: No such file or directory

apparently there are some loose wires

curious that it is targetting usb devices ??
I have inserted - but not yet connected an ext2 formatted memory stick

I can see that there are a number folders which are close but no cigar:
 

root@Teltonika-RUT955:~# ls /sys/bus/usb/devices/1-1.4/1-1.4*

/sys/bus/usb/devices/1-1.4/1-1.4:1.0:

authorized            bInterfaceProtocol    ep_01                 supports_autosuspend

bAlternateSetting     bInterfaceSubClass    ep_81                 ttyUSB1

bInterfaceClass       bNumEndpoints         modalias              uevent

bInterfaceNumber      driver                subsystem

/sys/bus/usb/devices/1-1.4/1-1.4:1.1:

authorized            bInterfaceProtocol    ep_02                 subsystem

bAlternateSetting     bInterfaceSubClass    ep_82                 supports_autosuspend

bInterfaceClass       bNumEndpoints         ep_83                 ttyUSB3

bInterfaceNumber      driver                modalias              uevent

/sys/bus/usb/devices/1-1.4/1-1.4:1.2:

authorized            bInterfaceProtocol    ep_03                 subsystem

bAlternateSetting     bInterfaceSubClass    ep_84                 supports_autosuspend

bInterfaceClass       bNumEndpoints         ep_85                 ttyUSB4

bInterfaceNumber      driver                modalias              uevent

/sys/bus/usb/devices/1-1.4/1-1.4:1.3:

authorized            bInterfaceProtocol    ep_04                 subsystem

bAlternateSetting     bInterfaceSubClass    ep_86                 supports_autosuspend

bInterfaceClass       bNumEndpoints         ep_87                 ttyUSB5

bInterfaceNumber      driver                modalias              uevent

/sys/bus/usb/devices/1-1.4/1-1.4:1.4:

authorized            bInterfaceSubClass    ep_89                 uevent

bAlternateSetting     bNumEndpoints         modalias              usbmisc

bInterfaceClass       driver                net

bInterfaceNumber      ep_05                 subsystem

bInterfaceProtocol    ep_88                 supports_autosuspend

root@Teltonika-RUT955:~#