subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,115 views 7 comments
by anonymous

I have a working setup with RUTX11 (on latest firmware) with 4G and all traffic over VPN (wireguard). To reduce 4G traffic I want to connect to public wifi when available in client mode (and also force all traffic over wireguard vpn connection).

Although it seems RUTX11 can connect in client mode to public wifi (which uses password, not hotspot), no internet traffic is possible.

From public wifi RUTX11 received IP, while RUTX11 LAN is on standard IP rang, so no overlapping ranges.

I have followed RUTX11 Wireless Client Mode, but somehow still no internettraffic possible.

Also moved new wifi interface to to the top (first interface) and restarted the RUTX11.

Maybe wireguard is somehow blocking internet traffic? But disabling wireguard also gives no internet traffic.

Any advice how to solve this issue?

3 Answers

0 votes
by anonymous

Seems related to Wireguard Multi-WAN issues/bug.

To be followed up in that thread by Teltonika engineer.

Best answer
0 votes
by anonymous


Thank you for contacting us.

I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration > Troubleshoot section and download troubleshoot file from there.

Best regards,

by anonymous
These troubleshooting files seems to contain quite a lot of info. When I upload these files, I suppose these will be visible for everyone? I have send you a PM.
by anonymous

Could you create a backup of your current configuration, then restore device's factory defaults (instructions here) and configure only Wifi as a client station to check if the functionality works and other configurations, or some leftover settings from migrating between firmware versions do not interfere.

by anonymous
Currently I cannot risk losing my VPN wireguard connection/set-up. Resetting to factory defaults might lead to losing this connection (if restoring backup file is somehow not working). However, your reaction seems to suggest no config error has been made and current settings should work.

I will try sometime later, will follow up on your advice later and report back then.
by anonymous

Steps I performed:

  1. Removed all simcards
  2. Reset to factory default (option in GUI)
  3. Performed initial setup (new passwords, etc.)
  4. Connect WAN to hotel LAN port. Result: internet is reachable.
  5. Further setup: new Wireguard connection to other Wireguard peer (act as "server"). Result: no handshake visible on Wireguard server, no longer internet traffic possible
  6. Disconnect WAN cable and insert SIM card. Result: Wireguard handshake is established and internet traffic is possible (after putting manual DNS servers in LAN interface). I made no (other) changes in (Wireguard) settings
  7. Also tested same hotel LAN with other device with same Wireguarf server. Result: connected and internet traffic possible

These results seem to suggest that a Wireguard VPN connection is not possible over WAN-LAN cable, only with SIM card WAN connection.

How to proceed with this issue?

0 votes
by anonymous
Today I tried again. First again reset to factory defaults, than also upgraded to newest firmware (also without keeping settings), now on version 7.02.05.

After setting everything again up, I have have working internet with 4G over Wireguard VPN.

Then again connected LAN cable to WAN. Saw that internal IP was assigned, but again directly no internet connection possible after connecting cable (also tried reboot).

I think this definitly is a bug to be solved, otherwise it will never work.

@ZygimantasBliu: if needed I can PM a new troubleshooting file from last try.
by anonymous


Make sure that the ISP is not blocking Wireguard connections. You you could try to use different port numbers, as some ports may be simply blocked.

Also, in the RUT Peer configuration window Advanced settings tab set the Persistent keep alive value to 25.

One more configuration option to check is to reduce MTU value in Wireguard interface Advanced settings tab.

Best regards,

by anonymous
Yes, keep alive was already on 25 sec. Yes, also MTU was already lowered to 1300. Also no block from ISP, checked with another device with same settings and same Wireguard server. Most likely this is Wireguard/Teltonika bug.

Can you investigate?
by anonymous
Just tested again. So in total I have tested this with four different ISP in three countries. Always same result: working 4G over Wireguard, but no internet when connected to WAN-LAN cable (or wifi in client mode).

Seems highly unlikely that all these ISP are blocking Wireguard on only Teltonika devices, but not on other devices with same setting.

Can any Teltonika support engineer follow on this Teltonika/Wireguard issue?