FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12692 questions

15070 answers

24150 comments

47148 members

0 votes
69 views 2 comments
by

Hi

I have 2 new RUT950 units running the latest firmware RUT9_R_00.07.02.6. I am trying to configure sim switch on "Data Connect Fail" using the ICMP method.  It isn't working there is no sim switch if I remove the targetted IP from my network.  And I see some output in the logread from the command line when save the settings.

Fri Sep  2 01:14:31 2022 kern.notice kernel: sim_switch configuration has been changed

Fri Sep  2 01:14:32 2022 daemon.info sim_switch[29825]: Starting sim_switch...

Fri Sep  2 01:14:32 2022 daemon.info sim_switch[29825]: Initializing uloop...

Fri Sep  2 01:14:32 2022 daemon.info sim_switch[29825]: Connecting to ubus...

Fri Sep  2 01:14:32 2022 daemon.info sim_switch[29825]: Reading configuration...

Fri Sep  2 01:14:32 2022 daemon.info sim_switch[29825]: [config_get_data_fail_iface:500] error: Failed to identify interface!

Fri Sep  2 01:14:32 2022 daemon.info sim_switch[29825]: Running...

In older versions of the firmware, you could specify the interface used to send the ICMP request, but it is missing in the latest firmware.

Any ideas?  Thanks

1 Answer

0 votes
by

Hello,

The logs you have provided are incomplete. A full troubleshoot file would be more helpful for further inspection of your case.

I have tried to replicate the issue, however, the sim switch event triggered successfully. The logs I have show the same order of the events, thus, I would suggest to check, how many attempts you have configured before the switch is triggered and how frequently the attempts are made, whch is determined by Check interval value.

Best regards,

by

Hi

Thanks for the quick response.  The log I sent was complete.  Nothing happens after the Fri Sep  2 01:14:32 2022 daemon.info sim_switch[29825]: Running... 

I waited for about 15 minutes, but the log had no more output.

I tried the same configuration on an older model RUT950 running software version FW version: RUT9XX_R_00.06.09. and it works as expected



Fri Sep 2 14:17:24 2022 user.info Messaged[1441]: Start from new event "CONFIG" "SIM switch co

nfiguration has been changed"

Fri Sep 2 14:18:21 2022 local1.crit sim_switch[1483]: ICMP fail: 2

Fri Sep 2 14:18:51 2022 local1.crit sim_switch[1483]: ICMP fail: 3

Fri Sep 2 14:18:51 2022 local1.crit sim_switch[1483]: Sim switch locked at /var/lock/sim_swich

.lock

Fri Sep 2 14:18:51 2022 local1.info sim_switch[1483]: Interface down...

Fri Sep 2 14:18:51 2022 local1.info sim_switch[1483]: Stop modem functions...

So my config works on version RUT9XX_R_00.06.09 but not on RUT9_R_00.07.02.6

Hi Again

For some reason, it has started to work.  Sorry, I must have messed up when I was configuring.

Thanks For your help.

by

Could you replicate the issue with RUT9_R_00.07.02.6, then access router's WebUI, go to System -> Administration > Troubleshoot section, download the file and attach it by editing your question.

Files are private and visible only to Teltonika Moderators.