FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
497 views 3 comments
by anonymous
I have a couple of RUT955 which are setup with OpenVPN TUN for remote access and internal TAP between the RUTs for a PLC-network for two different locations.
One of the devices has slow performance both in the WebUI and connection speed. When switching configurations between the devices, also with clean firmware install and "fresh configuration", the slow performance seems to follow the device.
The performance is well enough for the PLC-network but adding a camera stream really uncovers the difference in performance between the devices. Applies for both LAN, WAN and Mobil connections.

Do you have any advice how to boost performance on the slow RUT955?
Attached is the logfile from rebooting both devices in the full setup. I cannot see any particular issue but maybe get any information from it..

Attempted downgrading to FW 6 but the problem has existed from FW 7 and up to the latest  and now running FW RUT9_R_00.07.02.6

The slow performance device:
Product code
    RUT955T03XXX
Serial number
    1119533992
Hardware revision
    2017
Batch number
    0113

The good performance device:
Product code
    RUT955T03XXX
Serial number
    1109326173
Hardware revision
    1714
Batch number
    0096

1 Answer

0 votes
by anonymous

Hello,

I see no files attached.

Do both devices have similar configurations? Do both run the same services?

What CPU load does the slower device display in the Status -> Overview page? Could you compare the values between the devices? If one of those devices uses more processing power than the other, could you connect via CLI or SSH and execute the command top, to see what process causes the issue?

Best regards, 

by anonymous
Thanks for your replay!
I do not think the zip attached files are visible for other than Teltonika.

Both devices are tested with the same configuration running the same services. CPU/Load/RAM wise also seems really good, see screenshot below but thanks for the tip.
With limited traffic/operation with OpenVPN i see no issue and running for months without issues. But when using WebUI or trying more intense traffic (>1500kbps) the bad unit stands out. During such traffic the CPU load is between 10 and 16 % so i cannot see anything severe. When disabling all services and fresh install and just handling the WebUI I see major difference between the two devices in performance. With a fresh install also, the camera is streaming nicely on the good one but nearly not showing anything on the bad (same config/streaming options.). This is the same situation as my full setup.

The good unit:

Mem: 63228K used, 61604K free, 272K shrd, 6444K buff, 20084K cached
CPU:  12% usr   8% sys   0% nic  75% idle   0% io   0% irq   3% sirq
Load average: 0.27 0.38 0.28 2/73 9158

The bad unit:

Mem: 64116K used, 60716K free, 216K shrd, 6388K buff, 20160K cached
CPU:  11% usr   7% sys   0% nic  77% idle   0% io   0% irq   3% sirq
Load average: 0.25 0.34 0.25 1/65 17740
by anonymous

The files are still not visible, could you try to reupload.

You can try to reflash router's firmware via bootloader menu, following instructions here. Keep in mind, that this way the device can only be updated up to the latest legacy version. Update to 7.0 and above will only be available afterwards.

by anonymous
I am sorry - i did a mistake uploading the logfiles. Its now attached on the top.
Thanks I had not tried the bootloader option so i tried reflashing the router via bootloader and choose the last legacy firmware (06.09.2). Without changing any other settings i still see the performance difference between the devices. Installed latest firmware and still the same issue as described above, no difference.
Its driving me a bit creasy this issue