FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,261 views 0 comments
by

I want to add a wifi USB Stick to the RUT955. In OpenWRT this is possible installing the corresponding driver. In my case it is the kmod-rtl8192cu

Unfortunately I can not install the driver, can anyone help me?

root@RUT955:~# opkg install kmod-rtl8192cu

Installing kmod-rtl8192cu (3.18.23+2015-03-09-3) to root...

Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/base/kmod-rtl8192cu_3.18.23+2015-03-09-3_ar71xx.ipk.

Multiple packages (kmod-usb-core and kmod-usb-core) providing same name marked HOLD or PREFER. Using latest.

Collected errors:

 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-rtl8192cu:

 * kernel (= 3.18.23-1-b2f200610f46d20ef52d269421369d0c) * kernel (= 3.18.23-1-b2f200610f46d20ef52d269421369d0c) * kernel (= 3.18.23-1-b2f200610f46d20ef52d269421369d0c) * kernel (= 3.18.23-1-b2f200610f46d20ef52d269421369d0c) *

 * opkg_install_cmd: Cannot install package kmod-rtl8192cu.

root@RUT955:~# uname -a

Linux RUT955 3.18.44 #1 Fri Apr 5 10:23:58 UTC 2019 mips GNU/Linux

1 Answer

+1 vote
by anonymous
Hello,

Potentially Kernel version is outdated. Kernel version of the device cannot be updated/downgrated without major changes to routers SW.