FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,318 views 8 comments
by anonymous
Hi guys, maybe somebody could help me.

After upgrading firmware on rut 240 to last one, I  have no internet connection on lan.

I have an helium hotspot behind the router.

I can access the router gui and also the hotspot dashboard but seems that there is no internet connection on the lan port.

maybe somebody has an idea?

thx
by anonymous

Hi thx for your help.

Im not an expert so this is what i get when trying that command. 

2 Answers

0 votes
by anonymous

Hello,

Could you execute the following command on the RUT and retry to access external addresses:

  • ip -4 rule delete $(ip -4 rule show | grep 2062 | cut -d":" -f 2)

and / or the same command but using ip -6 if you use IPv6 ?

Regards,

by anonymous
Hi did not work in first try, maybe you could have a look if the command was correct? Thx
by anonymous
The command is correct, it may not be the solution but it was the easiest to try there was a bug in a previous version which was solved this way.

Check that forwarding from LAN to WAN is enabled in the firewall, and that the default route of the lan devices point to the RUT.

Do a tcpdump on the RUT and a ping 8.8.8.8 on a lan device :

tcpdump -i br-lan -n -v 'icmp and host 8.8.8.8'

Do you see something ?

Idem with tcpdump -i wwan0 -n -v 'icmp host 8.8.8.8'

Do you see the echo requests ? The echo replies ?
by anonymous

Hi, thx for your support. 

I think i can not manage the problem this way, and need to do a complete reset and hope that it works afterwards. 

For initial setup, i dont need “wired” access to the rut? It will provide  wifi right after reset to setup? Would make thinks much easier. 

Thx 

by anonymous

The command is tcpdump not cpdump and Idem was just an expression, not part of the command.

As the ping from the router itself is working the issue must be from the from the firewall (or an ip -4 rule but this has already been checked and excluded).

Redo the tcpdump -i br-lan -n -v 'icmp and host 8.8.8.8' on the RUT and a ping 8.8.8.8 from another device. What is the output of tcpdump ?

by anonymous

Hi, 

from the tcpdump i get back            -ash: tcpdump: not found

i can't ping 8.8.8.8 from connected device because portforwarding seems not to work after trying to get the problem fixed.

I add the troubleshoot file, maybe you could have a look. 

I changed a lot but nothing worked out.... 

In the meantime i found out that the default pw for wifi after reset is printed on the back of the router.... so i didnt have it...

Is there a way to get the info out of the router?

Thanks for your patience ;)

0 votes
by anonymous

Hello,

Thank you for contacting Teltonika Crowd Support.

Firstly, kindly access the device CLI and perform ping tests to external servers (e.g. ping 8.8.8.8). This will allows us to determine whether the RUT240 router has internet connectivity. You can go to CLI, log-in with root and your WebUI password and use ping command (ping 8.8.8.8) to see if you're able to reach WAN network.

Secondly, kindly access the RUT240 router's WebUI and navigate to Network - > Firewall - > General Settings and ensure that zone "lan" - > "wan" has "Accept" set on "Input", "Output" and "Forward"

May you kindly replicate the issue, download and attach the troubleshoot file from your RUT240 router. To get the troubleshoot file, please replicate the issue, then access router's WebUI and navigate to System -> Administration > Troubleshoot section and download troubleshoot file from there.

Note: If you have direct access to the RUT240 device i.e. if the RUT240 device is not in a remote location, you could try to restore it to default settings and start reconfigure it again. To restore the device to default settings, access the router's WebUI, navigate to System - > Backup - > Restore Configuration menu and press "Restore" button. 

Warm regards

Wesley

by anonymous
Hi,

Ping test is okay.

I tried a bit around with zones and firewall but with no luck.

I would try the delete -ip4 thing again, but as you see something was wrong what i tried.
by anonymous

Hello,

Thank you for the feedback.

Kindly note that you did not attach the troubleshoot file to the query thread. It is recommended that you replicate the issue, then generate, download, and attach the troubleshoot file using the instructions provided in the previous comment.

Alternatively, it might be easier to restore the device to factory default settings. To restore the device to factory default settings, access the router's WebUI, navigate to the "System -> Backup -> Restore Default Settings" menu, and press the "Restore" button. Kindly refer to the link below for further details:

https://wiki.teltonika-networks.com/view/RUT240_Backup#Restore_default_settings

Note: Please ensure that you have direct access to the RUT240 device i.e. if the RUT240 device is not in a remote location, before performing the "Restore to factory defaults" operation because this might make the device unreachable.

If you do not have the default WiFi password found at the back of the router, we recommend you ensure that you have direct access to the RUT240 device before performing the "Restore to factory defaults" operation.

Warm regards.

Wesley