FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12615 questions

14984 answers

23964 comments

46769 members

0 votes
160 views 2 comments
by
Hi,

I had a trouble to connect to Soracom Mobile with RUT2_R_00.01.13.1, RUT2_R_00.07.01.4.

And after upgrading to RUT2_R_00.07.02.6, it was resolved.

However I would like to confirm if it had been fixed officially or not.

And please tell us which version should we use to avoid this issue.

I attached the log.

It shows the RUT240 failed to executed some commands, saying 'command not found', after APN had been set.

```

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: gsm get: `+CGDCONT: 1,"IP","soracom.io","0.0.0.0",0,0,0,0

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: +CGDCONT: 2,"IPV4V6","","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: +CGDCONT: 3,"IPV4V6","ims","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: +CGDCONT: 4,"IPV4V6","","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,1`

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: PDP Type MATCH

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: gsm send: AT+QICSGP=1

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: gsm get: `+QICSGP: 1,"soracom.io","","",0`

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: gsm send: AT+CFUN?

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: gsm get: `+CFUN: 1`

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: gsm send: AT+CFUN=4

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: gsm get: `OK`

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: gsm send: AT+QICSGPEH=1

Wed Sep  1 07:42:45 2021 daemon.info unhandler[1936]: gsm get: `+QICSGPEH: 1,"soracom.io","","",0`

///

Wed Sep  1 07:43:01 2021 daemon.notice netifd: mob1s1a1 (14371): uqmi -d "/dev/cdc-wdm0" --timeout 3000 --set-client-id wds,"20" --start-network --apn "" --set-ip-family ipv4 --profile 1  --auth-type "none" --username "" --password ""

Wed Sep  1 07:43:01 2021 daemon.notice netifd: mob1s1a1 (14371): pdh4: "Call failed"

Wed Sep  1 07:43:01 2021 daemon.notice netifd: mob1s1a1 (14371): Unable to connect IPv4

Wed Sep  1 07:43:01 2021 daemon.notice netifd: mob1s1a1 (14371): Releasing client-id 20 on /dev/cdc-wdm0

Wed Sep  1 07:43:01 2021 daemon.notice netifd: mob1s1a1 (14371): Failed to create IPV4 connection

Wed Sep  1 07:43:15 2021 daemon.notice netifd: mob1s1a1 (14810): Stopping network mob1s1a1

Wed Sep  1 07:43:15 2021 daemon.notice netifd: mob1s1a1 (14810): Command failed: Not found

Wed Sep  1 07:43:15 2021 daemon.notice netifd: mob1s1a1 (14810): Command failed: Not found

Wed Sep  1 07:43:15 2021 daemon.notice netifd: mob1s1a1 (14810): Command failed: Permission denied

Wed Sep  1 07:43:15 2021 daemon.notice netifd: Interface 'mob1s1a1' is now down

Wed Sep  1 07:43:15 2021 daemon.notice netifd: Interface 'mob1s1a1' is setting up now

Wed Sep  1 07:43:16 2021 daemon.notice netifd: mob1s1a1 (14834): wwan[14834] Using wwan usb device on bus 1-1

Wed Sep  1 07:43:16 2021 daemon.notice netifd: mob1s1a1 (14834): wwan[14834] Using proto:qmi_wwan device:/dev/cdc-wdm0 iface:wwan0 desc:Quectel EC25

Wed Sep  1 07:43:16 2021 user.notice root: Looking /tmp/mobileon_1-1 flag

Wed Sep  1 07:43:17 2021 user.notice root: Modem is ready!

Wed Sep  1 07:43:22 2021 daemon.notice netifd: mob1s1a1 (14834): Using net device: wwan0

Wed Sep  1 07:43:22 2021 daemon.notice netifd: mob1s1a1 (14834): Informing driver of raw-ip for wwan0 ..

Wed Sep  1 07:43:22 2021 daemon.notice netifd: mob1s1a1 (14834): uqmi -d /dev/cdc-wdm0 --timeout 3000 --wda-set-data-format --link-layer-protocol raw-ip --ul-protocol disabled --dl-protocol disabled

Wed Sep  1 07:43:23 2021 daemon.notice netifd: mob1s1a1 (14834): [lock:35] error: Lock file detected!

Wed Sep  1 07:43:23 2021 daemon.notice netifd: mob1s1a1 (14834): Starting network mob1s1a1 using APN:

Wed Sep  1 07:43:24 2021 daemon.notice netifd: mob1s1a1 (14834): cid4: 20

Wed Sep  1 07:43:24 2021 daemon.info dnsmasq[4239]: read /etc/hosts - 4 addresses

Wed Sep  1 07:43:24 2021 daemon.info dnsmasq[4239]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses

Wed Sep  1 07:43:24 2021 daemon.info dnsmasq-dhcp[4239]: read /etc/ethers - 0 addresses

Wed Sep  1 07:43:24 2021 daemon.notice netifd: mob1s1a1 (14834): uqmi -d "/dev/cdc-wdm0" --timeout 3000 --set-client-id wds,"20" --start-network --apn "" --set-ip-family ipv4 --profile 1  --auth-type "none" --username "" --password ""

Wed Sep  1 07:43:25 2021 daemon.notice netifd: mob1s1a1 (14834): pdh4: "Call failed"

Wed Sep  1 07:43:25 2021 daemon.notice netifd: mob1s1a1 (14834): Unable to connect IPv4

Wed Sep  1 07:43:25 2021 daemon.notice netifd: mob1s1a1 (14834): Releasing client-id 20 on /dev/cdc-wdm0

Wed Sep  1 07:43:25 2021 daemon.notice netifd: mob1s1a1 (14834): Failed to create IPV4 connection

Wed Sep  1 07:43:25 2021 kern.info Leased 192.168.1.197 IP address for client 00:e0:4c:a5:05:e1 - TAKETOnoMBP in LAN

Wed Sep  1 07:43:37 2021 daemon.notice netifd: mob1s1a1 (15500): Stopping network mob1s1a1

Wed Sep  1 07:43:37 2021 daemon.notice netifd: mob1s1a1 (15500): Command failed: Not found

Wed Sep  1 07:43:37 2021 daemon.notice netifd: mob1s1a1 (15500): Command failed: Not found

Wed Sep  1 07:43:37 2021 daemon.notice netifd: mob1s1a1 (15500): Command failed: Permission denied

Wed Sep  1 07:43:37 2021 daemon.notice netifd: Interface 'mob1s1a1' is now down

Wed Sep  1 07:43:43 2021 daemon.info dnsmasq[4239]: read /etc/hosts - 4 addresses

Wed Sep  1 07:43:43 2021 daemon.info dnsmasq[4239]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses

Wed Sep  1 07:43:43 2021 daemon.info dnsmasq-dhcp[4239]: read /etc/ethers - 0 addresses

Wed Sep  1 07:43:44 2021 kern.info Leased 192.168.1.197 IP address for client 00:e0:4c:a5:05:e1 - TAKETOnoMBP in LAN

Wed Sep  1 07:43:44 2021 kern.info Mobile data disconnected (internal modem)

Wed Sep  1 07:46:06 2021 daemon.err uhttpd[2333]: Command failed: Not found

```

I attached a toubleshoot file which was taken with RUT2_R_00.07.01.4.

Sincerely,

Taketo

1 Answer

0 votes
by
Hello,

The troubleshoot file is not attached.

As for the firmware, you should always use the latest one available as it includes various improvements, fixes and occasionally new functionalities.

Best regards,
by

hi 

Here is the troubleshoot file.

Please check it. 

And could you please tell me from which version the issue is fixed.

https://community.teltonika-networks.com/?qa=blob&qa_blobid=11343034607496294410

by
The issue is related to your router not saving the manually entered APN value. From the logs it is quite clear that your APN does appear once, but is dropped in further AT commands. Even the configuration file shows manual APN as set, but the option with the APN value is missing.

This issue has indeed been fixed with latter firmware revisions.