FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
340 views 2 comments
by anonymous

We have many TRB140s that a script is used to configure using the uci command over ssh.  Recently upgraded from firmware TRB1_R_00.02.06.1 to the current "mass prod" firmware TRB1_R_00.07.02.4 because the older version (which has been working well) is no longer supported by a new batch of TRB140 hardware we received recently.

The script to configure them still works on 07.02.4, except for some of the network.mob1s1a1 settings, which after a reboot or network restart, revert to defaults.

For example if I run the following:

uci set network.mob1s1a1.force_apn=1
uci set network.mob1s1a1.apn=telstra.corp
uci set network.mob1s1a1.auth=pap
uci set network.mob1s1a1.username=lizzy
uci set network.mob1s1a1.password=2
uci commit
uci show network.mob1s1a1

It shows me that all of those settings are set properly.  They also exist in /etc/config/network

But then I run

reload_config
reboot

When the device reboots, those network.mob1s1a1 changes are gone back to factory default settings.

Am yet to try the latest version 07.02.7.  Will try that next, if not will start working my way back through older firmware versions until hopefully I find one where this still works before I hit a version that is no longer supported on newer hardware.

by anonymous
Working in version 07.00

Broken in version 07.00.1

Broken in version 07.02.7

Assume also broken in versions between 07.00.1 and 07.02.7
by anonymous

I think the problem is I was setting the following with older firmware:

simcard.@sim[0].force_apn='1'

But with firmware 07.00.1 onwards if I set

simcard.@sim[0].force_apn='-1'

then the network.mob1s1a1 settings seem to stick around after a reboot.

1 Answer

+1 vote
by anonymous
Hello,

The option 'force_apn' should indeed be equal to '-1' with the current firmware.
Best answer