FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
189 views 0 comments
by anonymous

Hello. So I've just bought a new TRB140 unit and have done a successful upgrade there, and then decided I should upgrade my old one I got last year too, which is still running TRB1_R_00.02.06.1.

The issue is that after I am shown the "Validation succeeded" page and click the "Proceed" button, the next thing I see is a a red message "Firmware update error. No image found.", and at the bottom of the page I see the following:

500 Internal Server Error

Sorry, the server encountered an unexpected error.

/usr/lib/lua/luci/controller/firmware.lua:68: attempt to index local 'f' (a nil value)
stack traceback:
	/usr/lib/lua/luci/controller/firmware.lua:68: in function 'get_magic'
	/usr/lib/lua/luci/controller/firmware.lua:437: in function 


I tried both the "Update from: Server" and "Update from: File" options. I even downloaded the TRB1_R_00.07.00_WEBUI.bin file which should correspond to the immediately following version to TRB1_R_00.02.06.1 according to this page: https://wiki.teltonika-networks.com/view/TRB140_Firmware_Downloads

What can I do about this?

Thanks very much.

1 Answer

0 votes
by anonymous

Alright I figured it out. Turns out you can do the update via CLI.

I uploaded the latest firmware image to the device:

scp TRB1_R_00.07.02.7_WEBUI.bin root@192.168.2.1:/tmp/

I run the update command:

root@xxxxxx:~# sysupgrade /tmp/TRB1_R_00.07.02.7_WEBUI.bin
OK
OK
Saving config files...
Commencing upgrade. Closing all shell sessions.
Connection to 192.168.2.1 closed by remote host.
Connection to 192.168.2.1 closed.

And it worked, my device is updated.  :)

Best answer