FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
691 views 3 comments
by anonymous
Hello,
My RUTX09 uses both WAN and 4G connections.
My failover setup is shown in the attached images.

Despite this configuration, my VoIP phones (10.0.0.240 and 10.0.0.241) register on the 4G connection and not the WAN (ADSL) connection.
Can you help me ?

4 Answers

0 votes
by anonymous

HI,

 

I looked at the pictures you provided.  They show that you have Load balancing selected in the top right corner, not Failover.  You can only select Load balancing or Failover not both.  With Load balancing selected, it will use the default_rule policy you have set for Priority 2. 

Load Balancing will also look at the ratio you have set.  You have MOB1S1A1 set at 4 and the WAN set at 1.  This means a 4 to 1 ratio, meaning 75% of traffic will go out the Cellular interface.  Here are a few links that provides more information regarding the Failover and load balancing options.

https://wiki.teltonika-networks.com/view/RUT955_Failover

https://www.youtube.com/watch?v=NldACudT9mM (failover video)

https://www.youtube.com/watch?v=hgF1LZXSsvs (Load Balancing Video)

 

Regards

0 votes
by anonymous

Thanks a lot for your help.

Here is my project: I would like to configure the failover as follows: load balancing for all peripherals EXCEPT for VoIP telephones, which will only use ADSL (more stable).
According to your advice, I deleted all the "failover" policies I had created, and I kept only two "load balancing" policies.

I put in "Source address" of the VoIP rule 10.0.0.240/31 to force the phones (10.0.0.240 and 10.0.0.241) to use this rule.
This rule uses the ADSL policy (load balancing) which has only a connection to the WAN output (ADSL router) :

However, it still doesn't work. The phones connect to 4G and not ADSL :-(

By the way: I can't delete the fourth interface (called Toto), although I deleted it from the list of interfaces.
Would you know how to do it?

Best regards

by anonymous

Hi,

Please try rebooting your device and check again. (This will also might help to remove the "toto" interface from the Failover/Load balancing panel)

If rebooting the device does not work, please change the current Ip address mask to /30 or /24 and check again.

If the indications above fail, please share your troubleshooting file.

https://wiki.teltonika-networks.com/wikibase/index.php?title=RUTX09_Administration&mobileaction=toggle_view_desktop#Troubleshoot_2

I look forward to reading your comments.

Regards.

0 votes
by anonymous

Hello,
Despite numerous attempts, it was impossible to get the failover to work as desired.
In addition, the "toto" interface remains displayed...
Troubleshoot file is here.
Many thanks for your help!

by anonymous
Hi,

Please log into the router via ssh or CLI (https://wiki.teltonika-networks.com/view/RUTX09_CLI ) and execute the following command:

vi /etc/config/mwan3

To edit this file, you will need some vi editor basic knowledge that you can find in the link below:

https://www.redhat.com/sysadmin/introduction-vi-editor

And here are some useful vi shortcut commands:

$ vi <filename> — Open or edit a file.

i — Switch to Insert mode.

Esc — Switch to Command mode.

:w — Save and continue editing.

:wq or ZZ — Save and quit/exit vi.

:q! — Quit vi and do not save changes.

yy — Yank (copy) a line of text.

p — Paste a line of yanked text below the current line.

dd - remove a line from the command mode.

Based on the above, please remove every line related to the toto interface. (This should be enough to delete that interface from your WebUI Failover panel)

The rules also should look like this:

config rule 'VoIP'

option sticky '0'

option proto 'all'

list dst_ip '0.0.0.0/0'

list src_ip '10.0.0.240'

list src_ip '10.0.0.241'

option use_policy 'balance_ADSL_LB'

config rule 'ADSL'

option sticky '0'

option proto 'all'

option use_policy 'balance_ADSL_LB'

list dst_ip '0.0.0.0/0'

list src_ip '10.0.0.62'

list src_ip '10.0.0.11'

list src_ip '10.0.0.1'

Try to replace your current rules with the one above, and let me know if it works for you.

Also, on the WebUI Failover panel, place the more specific rules above the default one to command the router to execute those rules before.

I will keep an eye on your comments.

Regards.
0 votes
by anonymous

Hi,

I followed your instructions, but without success.
I then chose to start from the factory configuration to be sure that intermediate updates would not have disturbed the configuration.
Well, the result is the same: impossible to force a connection to an IP address.

Here is my mwan3 file :

config globals 'globals'
        option mmx_mask '0x3F00'
        option rtmon_interval '5'
        option mode 'balance'

config interface 'mob1s1a1'
        option interval '3'
        option family 'ipv4'
        option enabled '1'

config interface 'mob1s2a1'
        option interval '3'
        option enabled '0'
        option family 'ipv4'

config interface 'wan'
        option interval '3'
        option family 'ipv4'
        option enabled '1'

config condition
        option interface 'wan'
        option track_method 'ping'
        list track_ip '1.1.1.1'
        list track_ip '8.8.8.8'
        option reliability '1'
        option count '1'
        option timeout '2'
        option down '3'
        option up '3'

config member 'wan_member_mwan'
        option interface 'wan'
        option metric '3'

config member 'wan_member_balance'
        option interface 'wan'
        option weight '2'

config policy 'mwan_default'
        list use_member 'mob1s1a1_member_mwan'
        list use_member 'mob1s2a1_member_mwan'
        list use_member 'wan_member_mwan'

config policy 'balance_default'
        list use_member 'mob1s1a1_member_balance'
        list use_member 'mob1s2a1_member_balance'
        list use_member 'wan_member_balance'

config rule 'ADSL'
        option sticky '0'
        option proto 'all'
        option use_policy 'balance_ADSL'
        list src_ip '10.0.0.240'
        list src_ip '10.0.0.241'
        list dest_ip '0.0.0.0/0'

config condition
        option interface 'mob1s1a1'
        option track_method 'ping'
        list track_ip '1.1.1.1'
        list track_ip '8.8.8.8'
        option reliability '1'
        option count '1'
        option timeout '2'
        option down '3'
        option up '3'

config member 'mob1s1a1_member_mwan'
        option interface 'mob1s1a1'
        option metric '1'

config member 'mob1s1a1_member_balance'
        option interface 'mob1s1a1'
        option weight '8'

config condition
        option interface 'mob1s2a1'
        option track_method 'ping'
        list track_ip '1.1.1.1'
        list track_ip '8.8.8.8'
        option reliability '1'
        option count '1'
        option timeout '2'
        option down '3'
        option up '3'

config member 'mob1s2a1_member_mwan'
        option interface 'mob1s2a1'
        option metric '2'

config member 'mob1s2a1_member_balance'
        option interface 'mob1s2a1'
        option weight '1'

config rule '4G'
        option proto 'all'
        list src_ip '10.0.0.1'
        list src_ip '10.0.0.62'
        option sticky '1'
        option timeout '600'
        option use_policy 'balance_4G'
        list dest_ip '0.0.0.0/0'

config policy 'balance_ADSL'
        list use_member 'wan_member_balance'

config rule 'default_rule'
        option dest_ip '0.0.0.0/0'
        option use_policy 'balance_default'
        option sticky '0'
        option proto 'all'

config policy 'balance_4G'
        list use_member 'mob1s1a1_member_balance'

by anonymous

I just realized that no rules are active!

root@Teltonika-RUTX09:~# mwan3 rules
Active ipv4 user rules:

Active ipv6 user rules:

Do you know why ?

root@Teltonika-RUTX09:~# mwan3 status
Interface status:
 interface mob1s1a1 is online 00h:04m:09s, uptime 02h:33m:59s and tracking is active
 interface mob1s2a1 is offline and tracking is not enabled
 interface wan is online 00h:04m:09s, uptime 38h:36m:31s and tracking is active

Current ipv4 policies:
balance_4G:
 mob1s1a1 (100%)
balance_ADSL:
 wan (100%)
balance_default:
 wan (20%)
 mob1s1a1 (80%)
mwan_default:
 mob1s1a1 (100%)

Current ipv6 policies:
balance_4G:
 unreachable
balance_ADSL:
 unreachable
balance_default:
 unreachable
mwan_default:
 unreachable

Directly connected ipv4 networks:
78.213.91.0/24
10.0.0.0/24
10.158.247.124
224.0.0.0/3
127.0.0.0/8

Directly connected ipv6 networks:
fe80::/64
fd3d:4bcf:cfa6::/64

Active ipv4 user rules:

Active ipv6 user rules: