FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
692 views 7 comments
by anonymous

We cannot find how to configure the RUT240 to use Wifi as WAN, and route all LAN traffic to wifi.

We want to connect a LAN device through the RUT240 to the Wifi network
In the previous firmware version (version RUT2XX_R_00.01.12.3), we could easily select the Wifi as WAN, and use DHCP on LAN to connect the device. When the zones are configured correctly, RUT240 will route all traffic from local LAN to Wifi. 

https://wiki.teltonika-networks.com/view/RUT240_WAN_(legacy_WebUI)

with the new firmware (the latest version available) we cannot find this setting and we are not able to make a connection. Seems that something is blocking us to create a succesfull connection in the latest firmware software.

https://wiki.teltonika-networks.com/view/RUT240_WAN

How can we setup the RUT240 to use wifi as WAN?
We now downgraded the RUT240 (to version RUT2XX_R_00.01.12.3 which is working for us) and could easily configure Wifi as WAN and now it is working! 

Then we upgraded the firmware again to the latest version available, and now it is not working anymore.
We now see that the Wifi is called WWAN (wireless WAN) but we can not assign this interface in the firewall zones.

We will downgrade again to get this working. But we hope somehow we can have this working in the latest firmware.

1 Answer

0 votes
by anonymous

Hello,
thank you for reaching out!

To configure WWAN (Wireless WAN) on your router you would need to navigate to Network -> Wireless and click on scan to find the desired WiFi network that you are trying to connect to. I would recommend checking out this Wiki article for a more detailed instructions:

https://wiki.teltonika-networks.com/view/RUT240_Wireless#Client_Mode


Alternatively, this video can also be used as a reference:

https://www.youtube.com/watch?v=INGKWNqnZZ0&ab_channel=TeltonikaNetworks


Please note, that this example is done on RUTX11, but configuration will be identical with the exception of 5GHz WiFi band option.

Best regards,

Daumantas G.

Best answer
by anonymous

Thanks for your reply much appreciated.
The thing that we are able to configure the WAN correctly on the firmware version RUT2XX_R_00.01.12.3, which is the version installed once you receive the RUT240. We have a working situation in that firmware version, we are able to setup the WAN interface and able to use it. 

Once we upgrade the firmware to the latest version available on Firmware Download page, version 
RUT2_R_00.07.02.7, the WAN interface is translated into WWAN and the connectivity is not working anymore. Looks like the firmware upgrade is somehow adding an extra feature or fw rule that makes it inpossible for us to connect. We tried to setup FW rules (Accept All) and routing rules but it is not working.

So we find it very very strange that on the "old" firmware we have a working situation but once we upgrade to the latest version we loose our connection. 

by anonymous

I'm sorry to hear that you're still having issues.

This could have been caused by software migration issue as you are upgrading from quite old Legacy firmware version and that might affect how firewall rules are configured.

It would be important to determine, whether this is caused by the device firewall settings. Could you please try stopping it for testing purposes by running: /etc/init.d/firewall stop via the command line?

Command line interface can be accessed via router's WebUI by switching router UI to advanced mode in the top right corner and going to System -> CLI and entering login details (username: root; password: password that you set for your router's WebUI).

More information on how to access CLI can be found here: 

https://wiki.teltonika-networks.com/view/Command_Line_Interfaces_RutOS#CLI_.28WebUI.29

If this doesn't help, that would indicate that there is a more serious issue and you might have to restore the device to default settings and reconfigure. That can be done by navigating to System -> Backup - > Restore default settings.

More information on resetting here: https://wiki.teltonika-networks.com/view/RUT240_Device_Recovery_Options#Factory_reset

NOTE: This will erase everything on the router!

However, if stopping the firewall would help, then we would need to take a deeper look into your firewall configuration, could you please download the troubleshoot file and attach it to this forum thread?

To download the troubleshoot file please navigate to System -> Administration -> Troubleshoot -> Download Troubleshoot

More information on where to find it:

https://wiki.teltonika-networks.com/view/RUT240_Administration#Troubleshoot_2

Note: make sure that you re-enable your firewall once you finish the test by running /etc/init.d/firewall start

Best regards,

Daumantas G.

by anonymous

Thanks for your reaction.
I have tried the following.
As you mentioned I used to command line, the results where after I used this command, I could make no ping, telnet or tracert command towards the server I would like to connect to.
So I started the firewall again using the following command: /etc/init.d/firewall start.
I am starting to investigate more and more into this matter and trying to collect as much information I can find.
Currently in use, firmware version: RUT2XX_R_00.01.14.6
Kernel version: 3.18.44
Bootloader version: 3.2.2

After I checked the firmware download page, I saw the message which upgrade is not possible, so I started to upgrade the firmware version to the next available version and try and see on which version on connection is crashing.

So the first step, I upgraded to the version RUT2_R_00.07.01.2, while .01 was removed on the Downloads page.

After the firmware was successfully upgraded from version RUT2XX_R_00.01.14.6 to version RUT2_R_00.07.01.2, I was not able to execute a successful ping or tracert command towards the receiving version.
I also opened the CLI command line and after running the command, this did not help and still no connection possible. I reversed the command by replacing START with STOP.
After that I tried to run the ping command within the CLI and i was able to send succesfull ping commands. Also the traceroute command was succesfull.
Tried to same from a desktop CMD and no success.
Conclusion: from the CLI in the RUTOS i can succesfully do a ping and traceroute command towards the server, via CMD command on the connected desktop this is not possible and gives the message: "Destination host unreachable."

So looking at this, it seems that if I switch from the old legacy OS to the new RUTOS WebUI my connection seems to collapse. I still have a workin WiFi connection towards our Corporate Network, however the server I would like to connect to is not reachable.
I have downgraded again to the Last Legacy Firmware and now it is working again.

by anonymous

Hello,

  • When upgrading to RUT2_R_00.07.xx.x, are you selecting the option "Keep settings" or not?
  • If yes, please try to either upgrade without keeping the settings or do a factory reset on the new firmware and reconfigure the setup from scratch.
  • If the problem persists, I'll require a troubleshoot file to diagnose this problem further. To download the troubleshoot file please navigate to System -> Administration -> Troubleshoot -> Download Troubleshoot. Then attach it to the original post. Troubleshoot files are only visible to Teltonika moderators.

Best regards,

Daumantas G.

by anonymous

I have done the following again.
In the menu of the current version installed, RUT2_R_00.07.01.2, I did a factory reset and the router rebooted.
After that I needed to create a new password which I did.
I established the WiFi connection towards our networking according the protocols we needed to use and i could see a 58% connection status, which is acceptable. That is working fine.
I did not change any other setting, I kept all the settings and did not touch anything else.
I opened the CLI command editor and logged in. I entered the ping and traceroute command and could see a succesfull response back. I opened a CMD command on the desktop which is connected to the router and I could now succesfully enter a ping and tracert command towards the receiving server.

Conclusion:
For now it seems to work, but I have to check again with the medical device attached in stead of the desktop but this looks good. How is this possible that all of a sudden this is working?
Also looking at future firmware upgrades, is it advisable and safe to upgrade to the latest versions, will I keep my working connection as we have it now?

by anonymous

Hello,

I'm glad it's working now!
 

This may have been caused by newer firmware dealing differently with WWAN and when the jump between software versions is too great, it may corrupt config files, or firewall rules may not translate well into the new version. Software migration issue in other words.

In the future, I'd recommend updating the device more often and making sure that you do not upgrade more than 2 firmware releases at a time. (we support 2 firmware steps/jumps at a time, so for example from RUT9_R_00.07.02.5 to RUT9_R_00.07.02.7 is supported, but from RUT9_R_00.07.02.5 to RUT9_R_00.07.02.8 is not and may cause software migration issues).

Following this upgrade pattern should prevent such things from happening and would also guarantee the latest security updates.

If there are any questions in the future, let me know!

Note: Your issues in particular may have been caused because the firmware was upgraded from Legacy to RutOS.

Best regards,

DaumantasG

by anonymous
Thanks for your reply.
I have tried you method for updating the firmware and I can confirm that I am now using the latest firmware available and I still have a working connection.
I updated the firmware by 2 releases at a time and it is working. Thanks for your help.