FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
614 views 5 comments
by anonymous
Following explicit instructions to install zerotier package does not work.  See the attached screen grab:

1 Answer

0 votes
by anonymous

It does seem to install.

Could you execute the command in the terminal to see if zerotier has a configuration file:

cat /etc/config/zerotier
by anonymous

Yes, I see a sample configuration file.

root@Teltonika-RUT240:/usr/bin# cat /etc/config/zerotier

config zerotier sample_config

        option enabled 0

        # persistent configuration folder (for ZT controller mode)

        #option config_path '/etc/zerotier'

        # copy <config_path> to RAM to prevent writing to flash (for ZT controller mode)

        #option copy_config_path '1'

        #option port '9993'

        # path to the local.conf

        #option local_conf '/etc/zerotier.conf'

        # Generate secret on first start

        option secret ''

        # Join a public network called Earth

        list join '8056c2e21c000001'

        #list join '<other_network>'

Before I had received your answer, I had done the following:
Found zerotier was not running so I started it
        cd /usr/bin
        ./zerotier-one &
I then joined by zerotier network
       root@Teltonika-RUT240:/usr/bin# zerotier-cli join <my network>
I then could see my network in my.zerotier.com and approved it.  It shows me on-line.
I then checked using the CLI
root@Teltonika-RUT240:/usr/bin# zerotier-cli listnetworks
200 listnetworks <nwid> <name> <mac> <status> <type> <dev> <ZT assigned ips>
200 listnetworks <my network> N8SL_Repeater 7a:2a:d8:c9:1b:30 OK PRIVATE ztwfuceuwj 192.168.193.184/24
I then tried to connect to my RUT240 from my PC Chrome browser by typing the IP address of 192.168.193.184 and received a connection refused message.
I then tried via SSH to the same IP but it would not connect via SSH either.
I suspect that I have to create a zerotier.conf file similar to the file I printed out.  I am not sure if zerotier will start automatically when I restart the RUT240
by anonymous

Hello,

Could you check if you have the following in the router’s firewall congiguration file /etc/config/firewall:

config zone 'vpn_zone'

                option name 'zerotier'

                option input 'ACCEPT'

                option forward 'REJECT'

                option output 'ACCEPT'

                option device 'zt+'

                option masq '1'

                option mtu_fix '1'

 

config forwarding

                option dest 'zerotier'

                option src 'lan'

 

config forwarding

                option dest 'lan'

                option src 'zerotier'

 

Then restart both ZeroTier and firewall:

               /etc/init.d/zerotier restart

               /etc/init.d/firewall restart

by anonymous

SSHing into the RUT240 from a Raspberry Pi (on my zerotier network) but physically on the same LAN network created by the RUT 240, I modified firewall per the directions.

I restarted firewall (showed an error).

I do not see zerotier but I have /usr/bin/zerotier-one so I restarted it.

No success!

From the /usr/bin directory, I then started zerotier-one using ./zerotier-one &

Next, I joined my zerotier network using zerotier-cli join <my zerotier network>

In my zerotier control panel I then saw a new device and authorized it.

I was than able to SSH into the modem from my PC using the new zerotier IP address and also to connect to the RUT240 WEBUI using <new zerotier IP address>/index.html

How do I automate this so it occurs at boot?  Also, this process creates a new request for authorization with a new MAC address on the zerotier control panel each time I do the above process.  How di I make it use the same one at each boot?

by anonymous

Enter the relevant commands to /etc/rc.local file via SSH or in the WebUI System -> Custom scripts section. 

The commands will be executed after the router finishes the boot process. You might want to add a delay, since the device may not yet be connected to the internet by that time. 

by anonymous
Yes - I agree that adding the commands to rc.local should work but it will result in a new device being created in my zerotier network with a new MAC address that will require approval in my zerotier dashboard and I will have to delete the old device.  Is there not a way to use the previous information - for instance saving it in a .ini file?