FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
226 views 1 comments
by anonymous
I configured the RS232 and RS485 as server with the mode "over IP". If the parameter "timeout" is set to 0 they do not start. Webgui says everything is fine but nothing happens, no listening port is opened and no process is started (checked out via ps command on cli).

When a timeout value is set e.g. 300s the servers are starting normal.

I checked this behavior with two firmware versions: RUT9_R_00.07.02.5 and RUT9_R_00.07.02.7

1 Answer

0 votes
by anonymous
Hello,

Thank you for your input.

Timeout configuration option basically sets a timer to monitor inactivity between client and server. When the timer reaches set value, connection is terminated. It kind of makes sense not to start the process at all if connection is set to be terminated immediately. I assume you expect that setting to 0 would result in an infinite connection time, but from the TCP standpoint infinite connections are problematic. Also, there is a limitation from the WebUI itself that the biggest accepted value is 32767. This can simply be a limitation of a web interface, I can consult with the development team, but it would be interesting to know more about your use case and needs.

Best regards,
Best answer
by anonymous
Hello,

Thank you for your answer.

 I understand the problem of an infinite timeout. My problem was that I used an older firmware (RUT9XX_R_00.06.09.2) before and it worked with the value 0. And after the update to latest firmware it didn't work without any message or hint. So I needed some hours to figure out why. For me the problem is solved, maybe the documentation could be updated with a hint that with zero timeout the server won't start.

Best Regards

Matthias