FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12615 questions

14984 answers

23965 comments

46774 members

0 votes
161 views 0 comments
by

I had a problem with RUTX14 with fw RUTX_R_00.07.02.7: I had traveled to Netherlands and modem had worked mostly fine until then. I then reset the configuration (by pressing the reset button for 8 seconds). After this the modem could not connect to operator and in the modem status page the "Operator state" was switching between "searching" and "denied".

I tried setting APN manually, downgrading the RUTX14 firmware, moving to different location etc but nothing worked. The problem was with specific SIM card (Elisa from Finland, trying to connect to Vodafone NL network, SIM worked on my phone) as with other SIM card (COOP Switzerland connecting to some other network) the modem worked just fine.

Finally today I tried upgrading the modem firmware from EG12EAPAR01A09M4G to EG12EAPAR01A11M4G which can be done from the CLI/ssh and this fixed the problem immediately. Below are the commands for the modem FW upgrade

opkg update
opkg install modem_updater
opkg install sshfs
modem_updater -g
modem_updater -i -v
modem_updater -i <modem_id> -v <firmware_version>

Modify the last command based on the output of the command before. I'm pretty sure you should not upgrade the modem firmware if you do not have these problems as you could brick your device.

I hope this helps someone else.

1 Answer

0 votes
by
Hello,

Thank you for sharing your issue and the details to solve it.

Best regards,