FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12615 questions

14984 answers

23964 comments

46770 members

0 votes
163 views 5 comments
by
I have 12 RUT240 updated to lates FW RUT2_R_00.07.02.7

I am very disappointed about the down/upload speed over 4G. I do have a Vodafone SIM and the average is 4mbit down, 1mbit up. When I use the same card, put it in a Huawei Gigacube right next the the RUT240 I do have 120mbit down, 40mbit up. Both at open window with full signal. even a 50€ android Blackview as hotspot is 10 times faster. Is there any trick I missed?

1 Answer

+1 vote
by

Hello,

I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there.

Best regards,

by
Hello and thank you for helping. The file is now attached.
by

The signal characteristics seem quite good.

Check if the automatically acquired APN is the actual suggested by your provider and, if necessary, set custom value in Network -> Interfaces by editing mobile interface settings and disabling Auto APN.

Currently, your router is connected to LTE band 1. I would like you to navigate to Network -> Mobile, set Band selection to Manual and try the following LTE bands separately: B3, B7, B20, B28. 

Otherwise, the device has old modem firmware. Thus, I would suggest to perform an update. Before attempting the update, you need to connect your router an alternative WAN source, either wired or wireless. Below are the the instructions:

  • Access your device via SSH and execute the following commands:
    • opkg update
    • opkg install modem_updater
    • opkg install sshfs
    • modem_updater -g
  • The last command will list available firmware versions. Next modify the following command:
    • modem_updater -i <ID> -v <VERSION>
      • <ID> - should be 1-1, however, in case of an error you should be shown a correct ID.
      • <VERSION> - enter the latest firmware version from the list of the previously executed command, it should be EC25ECGAR06A13M1G.
    • So the complete command should look like this:
      • modem_updater -i 1-1 -v EC25ECGAR06A13M1G.

See if that helps.

by
I updated the modem and followed your instructions. The GigaCube uses home.vodafone.de as APN. I set this manually in the RUT240, after that I tried different bands separetly. Turns out that B20 had the "best" performance with 10mbit down and 8mbit up. The other bands where at 5/2 or less. Still unusable device for me. I also tried a factory reset and made everything new with the same result. I attached the second log after my changes. I will try to get a SIM from another Provider later this day.
by
I took my RUT240 home and used my failover SIM. Different city, different provider, exactly the same issue. 5mbit up, 1mbit down. Put the SIM back in the TP Link router... 100d/40up. Thats really frustrating. I will open another RUT tomorrow at work and do the test again. As I said, I have 12pcs. RUT240.... :-/
by
Because we need approx. 400 Router per year for our office product we've thrown away the RUT240 now and used another manufacturer which worked out of the box with no problems and high databandwith. I would highly recomend to not use this product for professional use.