FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
705 views 8 comments
by anonymous
Hi Support i have a rut x11 with italian sim TIM, fw 7.02.7 i cannot send sms from the router, can you help me?

the same sim works with fw 7.02.5.

2 Answers

0 votes
by anonymous
I've work a lot for understand this problem and found a solution.

Sms are sent through LTE when you are on 4g network.

You need to check the correct Apn for your operator and set it into section interface of the Gui.

Not all Apn allow to send Sms.

It is not enough that you are able to connect to internet.

For Tim correct apn is 'ibox.tim.it' and not the automatic set 'wap.tim.it'

Before set it, the problem was on this parameter that you can check only by CLI

>uci show simcard

Check parameter force_apn.

It must to be set as '-1'

It is not present into the gui but it very important and also sometimes this setting will be lost when you update firmware.

Set this by this command

>uci set simcard.@sim[0].force_apn='-1'

>uci commit

Then reboot

Check the apn and set it correctly into the interface section and everything will works good.
Best answer
0 votes
by anonymous

Hello,

Are you getting any error messages, when sending SMS?

Have you tried resetting the router to it's factory default settings?

Could you try to login to the router via SSH and send SMS with the following command to see, what is displayed after command execution:

gsmctl -S -s, --sms --send "<NUMBER> <TEXT>"

I would also like you to attach a troubleshoot file to your question. Please, replicate the issue by trying to send a few SMS, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. 

Best regards,

by anonymous
not work tried all the possible ways, how i can attach a trubleshoot file?
by anonymous
Edit the question and attach it or send it to me in a private message.
by anonymous
Same problem

Is there any update?
by anonymous
root@Teltonika-RUT955:~# gsmctl  --sms --send "xxxxxx prova"
N/A
root@Teltonika-RUT955:~# gsmctl  -V
EC25EUGAR08A01M4G

Firmware version
RUT9_R_00.07.02.7
Firmware build date
2022-09-08 09:31:13
Internal modem firmware version
EC25EUGAR08A01M4G
Kernel version
5.4.147
by anonymous

Hello,

What you have provided is a backup file, not troubleshoot.

Could you try making following adjustments in the Network -> Mobile section:

  • Set VoLTE to on;
  • Set service mode to 4G (LTE) only.

Otherwise, I would like you to download a troubleshoot file from System -> Administration -> Troubleshoot section.

Make sure to perform several attempts to send SMS and calls before taking the troubleshoot file. 

Best regards,

by anonymous
Already set volte on and only 4g

Also restore to factory

I have sent troubleshoot by pm
by anonymous

What you have provided is a backup file, not troubleshoot.

It does not contain necessary logs.

Looking at the number representation, could you try adding 00 or + sign at the beginning. Italian prefix seems to be 39.

Also, could you try another number?

by anonymous
I've tried with +39 and also with 00 without any success

I've test everything, reset to factory..update.. no success

gsmctl result is always N/A

sorry for wrong file I have sent to you troubleshoot file now