FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
318 views 0 comments
by anonymous
Hey everyone,

i am trying to send AT Commands to the RUT955. I am using a Beckhoff PLC which is connected to the modem trough RS485.

I read something that in modem mode SMS utilities are not availablte through AT commands? Which setting do I need to use than?

Additionaly I think I have problems figuring out what is the correct syntax for the string I sent or recieve.
AT+CPIN? for example doesn't work. Do I need prefix or suffix?

thanks for the help!

(This question is also related to my previous question "RUT955: Sending SMS through TwinCAT 3 and RS485 connection")

1 Answer

0 votes
by anonymous

Hello,

Could you provide more details on what exactly does not work with AT+CPIN? command?

I have tried the following setup and had it working:

RS485 settings:

For communication, I used PuTTy serial client, with the following setup:

The primary window keeps showing output of AT+QCSQ command. To disable this, execute the command:

  • at+qcsq=0

Since you might not be able to see what is veing entered to the terminal, you need to enter the following command to enable local echo:

  • ATE1

Then execute AT+CPIN?

If you have issues with RS485 communication itself, check if your connector is correctly wired. For reference, check this thread and this wiki article.

Best regards,