FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
271 views 3 comments
by anonymous

I’ve noticed on the RUTX11 running firmware version 00.07.02.7, using WiFi WAN (set up as per https://youtu.be/INGKWNqnZZ0)…

The WWAN interface won’t take any notice when setting a custom DNS.

Network > Interfaces > WWAN > Advanced Settings > Use Custom DNS Servers > Set as CloudFlare 1.1.1.1 and 1.0.0.1

The weird thing is, my MOB1S1A1 interface will use the custom DNS entries which are applied to the WWAN interface (this shouldn’t happen) but the WWAN interface won’t use them! As soon as I remove the custom DNS entries from the WWAN interface, the mobile interface returns to the default carrier DNS.

It seems like there is a bug - the custom DNS entries aren’t corresponding to the correct interface, despite being set for a specific interface.

I have managed to replicate this behaviour even after a factory reset, following the YouTube video above, and then applying custom DNS to the WWAN interface.

Any recommendations? Is this a bug?

1 Answer

+1 vote
by anonymous

Hello,

Thank you for bringing this up.

I have replicated the issue and forwarded it to the development team.

Could you also provide the troubleshoot by attaching it to your question, where it would be possible to see your configuration and some logs. Make sure you replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there.

Best regards,

by anonymous

A couple of options that could be tested. These, however, are implemented by editing some configuration files by CLI/SSH:

  • file /etc/config/network
    • A dns_metric option can be added to prioritize DNS servers. 0 means highest priority. For example
config interface 'wan'
  option dns_metric '100'
  • file /etc/config/dhcp
    • you can add strictorder option, meaning that then servers will be used one by one as ordered in resolv file. Example:
config dnsmasq
  option strictorder '1'

by anonymous
I’m glad to hear you managed to replicate the issue. I have not yet had the chance to submit the log files.

However, it does seem to have started occurring as of firmware version 07.00 (the release notes state “New WebUI based on Vue.js 2.6.12”)

I downgraded to 02.06.1 and it works as intended.

I also note, the “Override MAC” function for my wwan interface does not work on 07.00 and above (including the very latest firmware release today, 07.03) - but works on 02.06.1.

So, it seems firmware 07.00 and above (I assume the new UI has issues applying the config to the correct interface) has an issue with advanced config on the interfaces.
by anonymous

There is indeed an issue with changing WiFi WAN interface's MAC, as the address is saved in the wrong configuration file. This is currently set to be resolved in 7.4 firmware version, however, you can try changing the address via CLI/SSH. The commands should look similar:

  • uci set wireless.@wifi-iface[1].macaddr='<MAC_address>'
  • uci commit
  • reload_config

Replace <MAC_address> with address of your needs.

Alternatively, you can edit the configuration file with a text editor, for example:

  • vi /etc/config/wireless

and add the following option under client interface settings by pressing i letter to start editing:

  • option macaddr '<MAC_address>'

Exit editing by pressing ESC, enter :wq and press Enter, then execute reload_config command.