FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12671 questions

15052 answers

24113 comments

47054 members

0 votes
65 views 1 comments
by
I'm setting up several RUT240 routers and trying to automate as much as possible. One of the things I need to do is ssh from the router to a RHEL Satellite server and run some shell scripts. This involves ssh with public key authentication. I can not get this to work with RutOS / Dropbear ssh client. I need to be able to set the same public key on all the RUT240s and get dropbear ssh client to use this key. Does anyone know how I could achieve this? Another alternative would be to install the dd/openwrt openssh client i suppose, but I'm not sure if that's possible on RutOS.
by
edit: I didn't think openssh was available with opkg as opkg search openssh doesn't return any results, however I found a similar question where opgk install openssh-client was used and that worked for me as well (the installation). I will check if this also solves my ssh pubkey issue.

1 Answer

0 votes
by

Hello,

I would like you to try the following:

In the WebUI navigate to System -> Administration -> Access control. There, under SSH section, set Enable key-based authentication option to on, and enter your key.

Best regards,