FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
373 views 1 comments
by anonymous

I think there is a bug in firmware RUTX_R_00.07.02.8. SNMP daemon crashes when I try to ask OID .1.3.6.1.4.1.48690.2.2.1.16.1 (Mobile data connection type). After that, SNMP does not respond to any queries. After restarting SNMPD, everything works perfectly until I try to read that OID again.

# snmpwalk -v 2c -c public 10.100.1.1 .1.3.6.1.4.1.48690.2.2.1.16.1

iso.3.6.1.4.1.48690.2.2.1.16.1 = Hex-STRING: 88 9D 7B
Timeout: No Response from 10.100.1.1

# snmpwalk -v 2c -c public 10.100.1.1 .1.3.6.1.4.1.48690.2.2.1.16.1

Timeout: No Response from 10.100.1.1

(restart snmpd)

# snmpwalk -v 2c -c public 10.100.1.1 .1.3.6.1.4.1.48690.2.2.1.16.1

iso.3.6.1.4.1.48690.2.2.1.16.1 = Hex-STRING: 88 9D 7B

Timeout: No Response from 10.100.1.1

gsmctl -t works and responds with "5G-NSA" or "FDD LTE" depending which network is in use.

That OID works on other devices (RUTXR1, RUT950, ...)

edit: Added troubleshoot file because modem update fails.

root@Teltonika-RUTX50:~# modem_updater -i 2-1 -v RG501QEUAAR12A06M4G
[000.000]: Version: QFirehose_Linux_Android_V1.4.8
[000.000]: Builded: Aug 31 2021 22:20:08
[000.000]: P: /dev/bus/usb/002/003 idVendor=2c7c idProduct=0800
[000.001]: C: /dev/bus/usb/002/003 bNumInterfaces: 5
[000.001]: I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=30
[000.001]: E: Ad=81 Atr=02 MxPS= 1024 Ivl=0ms
[000.001]: E: Ad=01 Atr=02 MxPS= 1024 Ivl=0ms
[000.001]: I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.001]: E: Ad=83 Atr=03 MxPS= 10 Ivl=9ms
[000.001]: E: Ad=82 Atr=02 MxPS= 1024 Ivl=0ms
[000.001]: E: Ad=02 Atr=02 MxPS= 1024 Ivl=0ms
[000.001]: I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.001]: E: Ad=85 Atr=03 MxPS= 10 Ivl=9ms
[000.001]: E: Ad=84 Atr=02 MxPS= 1024 Ivl=0ms
[000.001]: E: Ad=03 Atr=02 MxPS= 1024 Ivl=0ms
[000.001]: I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.001]: E: Ad=87 Atr=03 MxPS= 10 Ivl=9ms
[000.001]: E: Ad=86 Atr=02 MxPS= 1024 Ivl=0ms
[000.001]: E: Ad=04 Atr=02 MxPS= 1024 Ivl=0ms
[000.001]: I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff
[000.002]: tmp=/sys/bus/usb/devices/usb2/../driver, driver=../../../../../../bus/platform/drivers/xhci-hcd
[000.002]: qusb_noblock_open port_name = /dev/ttyUSB0
[000.004]: old software version: RG501QEUAAR12A05M4G
[001.006]: poll_wait events=POLLIN msec=1000 timeout
[001.006]: switch to 'Emergency download mode'
[001.009]: successful, wait module reboot
Stopping services..
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
 DO NOT TURN OFF YOUR DEVICE DURING THE UPDATE PROCESS!
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
Starting flasher...
[000.000]: Version: QFirehose_Linux_Android_V1.4.8
[000.000]: Builded: Aug 31 2021 22:20:08
[000.001]: fail to access /sys/bus/usb/devices/2-1, errno: 2 (No such file or directory)
[000.001]: src/firehose/qfirehose.c firehose_main_entry 331 fail
Script finished

1 Answer

0 votes
by anonymous

Hello,

Thank you for reaching out!

I've tested SNMP on RUTX50 and it seems to return the connection state correctly:

I think the issue may be in the firmware version of your modem. We've seen reports of similar issues with an older version. To update the modem, please follow these steps:

  • Plug the router into an alternative WAN source (WiFi, Ethernet, etc.). This is important, as the modem will not update otherwise;
  • Log into the router WebUI, navigate to System → CLI and log in (username is root); SSH may also be used if preferred;
  • Then we'll need to install two packages: modem_updater and sshfs. To update all repositories, first, run opkg update. There may be some errors shown at the end of the update. Ignore them.
  • Then the packages can be installed by running the command opkg install modem_updater && opkg install sshfs
  • To find the latest modem firmware version, run the command modem_updater -g. Version numbering is usually indicated by the 4th and 5th numbers from the right (e.g. RG501QEUAAR12A05M4G).
  • After successfully finding the latest version, the modem can be updated. Run the command:

modem_updater -i [device_ID] -v [latest_version]

  • device_ID is usually 2-1, but it may be different on your device. If it's wrong, an error message will show the correct ID.
  • After the update has begun, make sure the power to the device is not interrupted!

Hopefully, this will help with the issue. If it does not, please replicate the problem and generate a troubleshoot file by going to System -> Administration -> Troubleshooting, and attach it to the original post. It will only be visible to Teltonika moderators.

Best regards,

Daumantas G.

by anonymous

Hello,

sorry, I did not notice the edit on the original post.
I've also replicated this issue and have sent a request for more information from RnD.

I'll let you know the next steps once I gather enough information.

UPDATE: 5G modems currently do not support this function, but this issue should be fixed in future updates.
We apologize for any inconvenience caused.

Best regards,

Daumantas G.