FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
334 views 3 comments
by anonymous

Hey there,

i have a Fritz!Box 7590 at my work with a static IP.

My Company gave me this Informations to connect to them:

  • VPN Type: "IPSec" or "IPSec Xauth PSK"
  • Public Server IP
  • ID IPsec
  • Shared Secret Key
  • Username
  • Password
I wish to connect my RUTX12 Router via 4G to the company network.
My RUTX12 has a private IP on the WAN side.
Is it possible to connect to the company with IPSec?
I tried this manual, but this doens't work for me:

1 Answer

+1 vote
by anonymous

Hello,

It should be possible to connect to your company with IPSec, as long as your RUTX12 has internet connectivity.

Based on the data you have provided, some key information is missing, mainly remote subnet of your company, and IKE proposal settings. These must match on both sides for the tunnel to establish. 

Also, do you want to simply access your company's network or route all of your traffic through the IPsec tunnel, in regards, to Default route option? 

A very detailed explanation, on configuring IPsec between Teltonika and Fritzbox is provided here, however, the configuration was performed on legacy design web interface, thus there are some differences.

Best regards,

by anonymous
Thanks for your reply.

Network of the Remote Net is 192.168.178.0/24.

should i set These network in the RUTX Router.

Ikev1 is used.

I am unsure becausethe mobile network has a private ip.
by anonymous
It does not matter if you have a private IP as long as you have internet access and the server has a public IP.

You are indeed correct. Set the following in RUTX IPsec configuration:

Local subnet as: 192.168.1.0/24 (your device's network)

Remote subnet: 192.168.178.0/24
by anonymous

Hey,

i tried it with these manual, but the interface look completly different to me.

Can you make a updatet manual for the newest RUTX Firmware?