FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12615 questions

14984 answers

23964 comments

46769 members

0 votes
35 views 1 comments
by
Hello,

I am trying to setup data limit trough CLI.

the wiki commands are not working.

they give back that uci doesnt know the entry.

Br,

Tansu
by
Found it if anyone needs.

quota_limit.mob1s1a1=interface

quota_limit.mob1s1a1.wrn_sent='0'

quota_limit.mob1s1a1.sim='1'

quota_limit.mob1s1a1.modem='1-1'

quota_limit.mob1s1a1.ifname='mob1s1a1'

quota_limit.mob1s1a1.due_reset_time='1669852800'

quota_limit.mob1s1a1.previous_period='3'

quota_limit.mob1s1a1.previous_reset_day_hour='1'

quota_limit.mob1s1a1.enabled='1'

quota_limit.mob1s1a1.enable_warning='0'

quota_limit.mob1s1a1.data_limit='1000000'

quota_limit.mob1s1a1.period='3'

quota_limit.mob1s1a1.reset_day='1'

quota_limit.mob1s2a1=interface

1 Answer

0 votes
by

Hello,

A complete set of commands would be similar to the following:

  • uci set quota_limit.mob1s1a1.sim='1'
  • uci set quota_limit.mob1s1a1.modem='<modem_ID>'
  • uci set quota_limit.mob1s1a1.ifname='mob1s1a1'
  • uci set quota_limit.mob1s1a1.data_limit='<data_limit_MB>'
  • uci set quota_limit.mob1s1a1.wrn_sent='0'
  • uci set quota_limit.mob1s1a1.due_reset_time='<limit_clear_time>'
  • uci set quota_limit.mob1s1a1.previous_period='<day - 1, week - 2, month - 3>'
  • uci set quota_limit.mob1s1a1.previous_reset_day_hour='0'
  • uci set quota_limit.mob1s1a1.enabled='1'
  • uci commit
  • reload_config